Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • silverbullet767
    Post count: 6

    Hi, I have just purchased my first raspberry pi and installed retropie plus a few roms.

    I followed this guide.

    I can get everything to work correctly with the emulators but I am having a few problems.

    1. I have scan lines when playing games, sort of like a stippled effect both horizontal and vertical on the screen. I am running through HDMI onto a HDTV.

    2. I am experiencing controller input lag on SNES and Megadrive (Mario world and sonic, the only 2 games I’ve tried so far) I have a USB retrolink SNES style controller, I have the pi overclocked to high settings.

    3. When following the linked guide, I got to this part and couldn’t go any further.

    Making EmulationStation Look Pretty

    Now that you have a sweet micro retro gaming rig, it’s time to make it look nice. Plug in a keyboard into your Raspberry Pi and turn it on. When it boots into EmulationStation, press F4 to quit. This will bring you back to the terminal.

    cd RetroPie/supplementary
    git clone
    cd RetroPie-Setup
    sudo ./

    it asks for a username when I should be typing cd and it asks for a password when I should be typing cd

    I fail to authenticate.

    What I need as a brand new user is an idiots guide to fixing these things, especially the first 2 issues, the last I’m not fussed about. I mean, what I need to type etc…

    Thanks for reading!

    Post count: 57

    Hey there, welcome to the forum.

    1. The scan line issue is just the emulator outputting scanlines, you can edit a configuration file and turn scanlines off, its just a feature that tries to make it the emulation look “authentic” :)

    2. The controller lag could be a memory problem, I haven’t come across this issue myself but I know that it happens.

    3. I assume that when you power on your Raspberry Pi it loads EmulationStation straight away? Whats happening is that when you exit EmulationStation the system is asking you to login, if you haven’t changed any of the passwords/usernames then the default settings are:

    Username: pi
    Password: raspberry

    Just a couple of questions

    Which Raspberry Pi are you using?
    Have you tried any other emulators to see if the lag is universal?

    Post count: 6

    Thanks for your reply!

    1. How do I edit this configuration file? What commands do I use? What parts of the file do I edit?

    2. I set the memory to 256/256 split. Is because I had a keyboard plugged in at the same time?

    3. Yes it starts emulationstation on boot. I tried pi, and raspberry but they didn’t work.

    To answer your questions.

    Raspberry pi model B

    I have only tried the MegaDrive emulator and the SNES emulator. The standard ones packaged with RetroPie SD Card image 1.10.1

    Post count: 908

    I need help about the scanlines, too. Can you please write how to turn them off.


    Post count: 57

    Most of the audio and video settings can be edited in two ways.

    1. Within emulationstation there is an “Input Configuration” screen, there is an option called RGUI, this is the retroarch configuration menu. Here you can edit pretty much everything, just remember that you need to “Save Config on Exit”

    2. Edit the actual text in the .cfg file.
    Many of the emulators are configured with one file, this file is called retroarch.cfg (and is the same one that is edited with the RGUI menu). The filepath is > /home/pi/RetroPie/configs/all/retroarch.cfg

    Now you can edit this file within the terminal or you can connect to your P remotely and edit the file.

    So far so good, now you need to know what to edit, basically you want to DISABLE video shaders.

    The config line is video_shader_enable = " "
    Between the quotation marks you can have two settings, “true” or “false”, basically on and off.

    Now thats not all!

    If you look in /home/pi/RetroPie/configs/ there is a folder some of the emulators, like nes and snes.

    In those folders is another retroarch.cfg, what this one does is allow you to make additional changes for each individual emulator, so you could have filters and shaders on one, different audio settings for another, or a different joypad configuration for all of them, this makes customisation better so if you are having problems with performance in one emulator you can turn everything off, and in another turn everything on.

    Go check each retroarch.cfg file for each emulator you are using in their respective folders. They may have video shaders enabled in that file, disable them if you want to turn it off.

    Anyway I need breakfast, good luck!

    Post count: 6

    Thanks for the reply, so if I wanted to edit the files from the raspberry pi itself what would I type to edit it?

    Would it be (i’m still learning linux)

    sudo – super user?
    nano – text edit?

    sudo nano /home/pi/RetroPie/configs/all/retroarch.cfg

    find the video_shader_enable = ” ” line

    change from
    video_shader_enable = “true”


    video_shader_enable = “false”

    Would that work?

    Also, I heard PiSNES works better than the default one. Would this already be installed as part of the 1.10.1 retropie image? Or will I have to download it?

    And how do you switch to it?

    Post count: 57

    Yeah you got all the commands correct so that should work fine.

    PiSNES runs great, just doesn’t support as many games as the retroarch emulator. It is installed with the standard image and should work fine, otherwise you can download the binary version and install it yourself.

    Its relatively easy to switch emulators.

    Emulationstation is the GUI that displays all the emulators, when you start a game it will issue a command to the emulator to load and to load that specific rom.

    You can edit the emulators that emulationstation runs by editing es_systems.cfg
    this can be found here > /home/pi/.emulationstation/

    If you scroll down that file to the Super Nintendo then it should have a couple of COMMAND=/home/pi......... lines, the # at the front stops that command from being issued, so only the one without the # tag will run. All you have to do is remove the # from the pisnes command line, and then add # to the original command line.

    So it should look like this :

    DESCNAME=Super Nintendo
    EXTENSION=.smc .sfc .fig .swc .SMC .SFC .FIG .SWC
    # COMMAND=/home/pi/RetroPie/supplementary/runcommand/ 4 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/pocketsnes-libretro/ --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/snes/retroarch.cfg   %ROM%"
    # COMMAND=/home/pi/RetroPie/emulators/snes9x-rpi/snes9x %ROM%
    COMMAND=/home/pi/RetroPie/emulators/pisnes/snes9x %ROM%

    Then save es_systems.cfg and reload emulationstation, now it will boot pisnes for snes roms.

    Post count: 6

    Brilliant!, thank you, hopefully running PiSNES solves the controller lag I’ve been experiencing.

    As long as PiSNES runs super mario world, mario kart, f-zero, and a few other early games I’m not that fussed.

    Would having a keyboard and a USB RetroLink SNES controller plugged in at the same time cause a little lag due to power consumption? Should I change the overclock setting from HIGH to MEDIUM to solve this?

    I’ll report back tomorrow when I get a chance to configure everything tonight.

    Post count: 6

    Got it!!!

    I did everything suggested but it didn’t make any difference.

    But if you type

    sudo nano /RetroPie/configs/snes/retroarch.cfg

    THATS the setting that overwrites any previous settings.

    you can change it for each emulator just substitute snes for megadrive etc.

    I also changed my overclock to HIGH and memory split to 384/128 and switched to pisnes and it works perfectly now. NO controller lag!

    Thanks guys.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.