Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • reaver63
    Post count: 10

    Hello! i’m using a 16gb USB drive to load roms without copying them on the sd card.
    But when i’m playing on EmulationStation, i can’t save state.
    It says “Failed to save state to “/media/usb/Snes” or something like that.

    So i searched everywhere, and found a solution: use gparted to format the USB drive in EXT4.
    I did it, and it didn’t worked.

    Does somebody can help me?

    Post count: 908

    This happened to me, and the problem was insufficient space on SD.

    See if the USB or SD card has sufficient space.

    Post count: 10

    Okay, i fixed it with the sudo chmod 777 * to set the permissions ! Solved! ^^

    Post count: 2


    I’m facing the same problem, I run my roms from my usb dongle (which has plenty of free space (~31Go free)).

    I tried to use the chmod command : sudo chmod 777 /media/usb0 but it still doesn’t work… Any idea?


    Post count: 1827

    probably because the folder below it are not writeable.

    if using fat32 – you should make sure it is writeable to the user you will be using. this can be done with mount options.

    if mounting via fstab

    if using usbmount

    Post count: 2

    Hi thanks a lot for your answer (sorry to answer so late I thought I’de receive a mail as notification of answer…guess I forgot to tick the notification box…)

    I’m must admit I’m quite a noob with programmation.

    I found somewhere that I’d have to allow writing on the Usb drive using :

    sudo chown -R pi:pi /media/usb/

    Then I’d be able to do the chmod trick :

    sudo chmod 777 /media/usb0

    Does this seems correct to you?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.