Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 8

    Hello,

    I’ve read many topics of this forum to set up retropie. Most things work but the USB HDD kills me. I tried any suggestions I have found but nothing seems to work.

    I took a 320gb WD Blue from my Thinkpad which I’ve replaced with a SSD and bought a SATA to USB adapter.

    It shows up and I was able to format it. But I can’t access it respectively it seems so and there are no Rom folders created.

    pi@raspberrypi ~ $ lsusb
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Bus 001 Device 006: ID 1241:1503 Belkin Keyboard
    Bus 001 Device 007: ID 152d:2509 JMicron Technology Corp. / JMicron USA Technology Corp. JMS539 SuperSpeed SATA II 3.0G Bridge
    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    81 heads, 63 sectors/track, 122504 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00015dda
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            2048   625142447   312570200   83  Linux

    And it does not show up here even it’s said above that it’s listed under /dev/sda1:

    pi@raspberrypi ~ $ blkid
    /dev/mmcblk0p1: LABEL="RECOVERY" UUID="6782-8AD5" TYPE="vfat"
    /dev/mmcblk0p3: LABEL="SETTINGS" UUID="ae7ba22e-7f25-4575-97bb-b695ef0d2ee4" TYPE="ext4"
    /dev/mmcblk0p5: LABEL="boot" UUID="2B9B-8307" TYPE="vfat"
    /dev/mmcblk0p6: LABEL="root" UUID="c0fc5f89-e5e9-4aa2-b08b-b0617145c24c" TYPE="ext4"

    It says also the HDD is already mounted:

    pi@raspberrypi ~ $ sudo mount /dev/sda1 /media/usb0
    mount: /dev/sda1 already mounted or /media/usb0 busy
    mount: according to mtab, /dev/sda1 is already mounted on /media/usb0

    I couldnt mount it to /hdd1 which i created before and mounted it to usb0.

    So, I dont know if there is a problem with the HDD or I’m just doing something wrong while trying to use it. At some point it said that there is a read-only permission.

    How can I now use my HDD so I can place all the Roms there?

    pattaboy
    Participant
    Post count: 44

    I think an external HDD won’t be able on a raspberry pi.
    The HDD needs to have enough energy to spin the internal drive.

    USB Sticks will work because they don’t need a lot of powe.

    Anonymous
    Inactive
    Post count: 8

    Oh, sorry. I forgot to mention that my HDD is plugged into a powered USB hub. I thought that would be sufficient. Or isn’t it?

    pattaboy
    Participant
    Post count: 44

    [quote=93139]Oh, sorry. I forgot to mention that my HDD is plugged into a powered USB hub. I thought that would be sufficient. Or isn’t it?[/quote]

    haven’t tried it out yet.
    You can check if you listen to the case. do you hear it spinning?

    and do the lights flash?

    Anonymous
    Inactive
    Post count: 8

    Yes, it spinns and the led of the adapter indiciates that it’s working.

    InsecureSpike
    Participant
    Post count: 571

    you cold see if either of these help

    Power 2.5″ Hard Drive with Raspberry Pi 2 and B+

    there maybe something in those that could help! i would try the max_usb_current=1 method first
    i have a wd elements with my file system on and no external power, and alls good!

    moving file system to usb/hdd
    http://www.raspberrypi.org/forums/viewtopic.php?f=29&t=44177&hilit=move+root+fs+usb+tutorial&sid=2503f9ffe9afaa2edb49aef4537a862a

    Anonymous
    Inactive
    Post count: 8

    So… I used the max_usb_current=1 method and it seems to work (and I look forward to move the filesystem to the hdd, thx Spike).

    I got the HDD mounted to /media/hdd1.

    Now it tells me that I have no rights e.g. to create a directory. I did it in command line with sudo, but I wonder how I am able to get my roms there and if I have to create the folders manually. Because the usbromservice doesnt create them.

    Or is it necessary/possible to remove this restriction?

    InsecureSpike
    Participant
    Post count: 571

    awesome! thats great!
    ok, so have you followed either of these 2 methods?

    How to run from USB

    moving file system to usb/hdd (i use this method)
    http://www.raspberrypi.org/forums/viewtopic.php?f=29&t=44177&hilit=move+root+fs+usb+tutorial&sid=2503f9ffe9afaa2edb49aef4537a862a

    Anonymous
    Inactive
    Post count: 8

    It’s wonderful. Thank you so much!

    InsecureSpike
    Participant
    Post count: 571

    your welcome! good luck!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.