Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • kkspike
    Participant
    Post count: 3

    Hi, so here is my situation:

    -Bought and soldered the GPIO SNES adaptor for Retropie
    -Installed from scratch the latest version of the Retropie SD image
    -Installed SNESdev from the setup program
    -Tested both controllers with jtest (the js0 and js1 joypads were inverted, I -switched them on the GPIO adapter and it works nicely, now)
    -Launched emulationstation and was able to configure both controllers just fin4
    -Launched a ROM and was able to play (both player 1 and player 2)
    -Now on to my problem:
    -While in a ROM (SNES or NES), I can use the ESC key to quit the emulator and be brought back to emulationstation.
    -While in a ROM (SNES or NES), I can use the button on the GPIO adapter to quit the emulator and be brought back to emulationstation.
    -I want to configure a button combo on my joystick that will do the same thing as ESC or (3x) button on GPIO.

    Where do I have to put the following lines?
    input_enable_hotkey_btn = “6”
    input_exit_emulator = “4”

    I have tried in /opt/retropie/emulators/RetroArch/configs/SNES-to-GamepadDevice.cfg but it did not work. There are so many .cfg files involved that I must admit I’m kind of lost.

    Everything else is working great (still have to tweak overclocking to resolve some sound issues in some games, but it’s ok)

    Thanks for the help!

    petrockblog
    Keymaster
    Post count: 1827

    You should be able to press SELECT + LEFT SHOULDER BUTTON (or START + LEFT SHOULDER BUTTON, not sure right now). That should do the trick already.

    Note, however, that this does only apply for RetroArch-based systems.

    kkspike
    Participant
    Post count: 3

    It is indeed SELECT+Left shoulder pad but I does nothing while I’m in a SNES game. Is the supplied snes emulator a retroarch system?

    Mike
    Guest
    Post count: 908

    those settings work with the default retropie snes emulator for me, they should also work in the nes, genesis, and playstation emulators, if it doesn’t work in those emulators as well something is not setup right in your retroarch.cfg file

    kkspike
    Participant
    Post count: 3

    Where did you put the input_enable_hotkey_btn and the input_exit_emulator settings? In the SNES-to-gamepad.cfg or the retroarch.cfg file?

    Floob
    Member
    Post count: 1629

    I put mine in here
    SNES-to-gamepad.cfg

    doublej
    Participant
    Post count: 2

    Hello
    I am having the same issues with my controller, I have a SNes remote and all the controls work except the hotkeys. I’ve tried putting the codes into different areas and it still does not work in any of the emulators. Can someone please point me in the right direction to resolve this issue? I am running the newest version of retropie 2.3.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.