Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • moofy
    Post count: 2

    hi everyone i really need some help with getting my controllers automatically recognized in emulationstation. i used to put gamecon_gpio_rpi map=0,0….. in /etc/modules and it would work great in older retropie versions. but now i notice it does not work in retropie version 3.6, however if i type sudo modprobe gamecon_gpio_rpi map=…..and then start emulationstation from the console the controllers work no problem. Typing regular modprobe gamecon_gpio….. gives me permission problems. Anyway i would prefer the controllers to be automatically detected without having to plug in a keyboard and typing some commands. Does anyone know how i can achieve automatic gpio controller detection with gamecon? thank you for any help!

    Post count: 2

    Create a file called ‘gamecon.conf’ in /etc/modprobe.d/
    sudo nano /etc/modprobe.d/gamecon.conf

    Add this single line (remember to replace ‘map=0,0,2,0,0,0’ with your own configuration):

    options gamecon_gpio_rpi map=0,0,2,0,0,0

    Now in /etc/modules just use module name and remove the map parameter:



    Post count: 2

    ffio i am very grateful to you, i have done as you instructed and now my controllers are working at startup time. Thank you again for spending your precious time to come to the aid of a complete stranger. Now i can move forward in my project, and so i appreciate every word you typed in. Thank you kind person.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.