Homepage Forums RetroPie Project Controller Configuration in RetroPie Enabling SNES multitap on cores OTHER than Snes9x?

Viewing 1 post (of 1 total)
  • Author
  • #100675

    Hi everyone, first the summary:

    Pi Model: 2 B
    RetroPie Version Used: 3.0 Beta 2
    Built From: SD Image
    USB Devices connected: 4x Buffalo Classic USB Gamepad through 4 port Rosewill powered USB Hub Canakit wifi dongle, Microsoft USB Keyboard are plugged directly into the RP, with a Microsoft mouse plugged into 1 of the 2 USB ports on the keyboard.
    Controller used: 4x Buffalo Classic USB Gamepad

    How to replicate the problem:

    Run Super Bomberman 5 on lr-snes9x-next (or previous versions of the core), it will freeze audio at the menu, but video will keep going until you press any key, and then video will freeze also.


    Run Super Bomberman 4 on lr-snes9x-next(or previous versions of the core), it will freeze audio and video during the intro cinematic.

    I’m building an emu box for my friend’s birthday. The most important game, the one he will want to play is Super Bomberman 5 for SNES (with Super Bomberman 4 being a close second), with 4 people at a time.

    I’ve tested Mario Kart 64 with all 4 controllers, and apart from garbled textures and unreadable menus, all 4 people can play once we hit the actual race track!
    Also, running Castlevania SOTN and Parasite Eve for PS1 just fine, and very impressed by retropie in general, so awesome.

    Here is my problem: Every version of Snes9x I’ve tried on retropie has crashed at the menu for SB5 (and even earlier in SB4). All other SNES cores I’ve tried do not have this problem, however I can’t get more than 2 controllers working for them. I got multitap support working for Snes9x via adding this line to /opt/retropie/configs/snes/retroarch.cfg:

    input_libretro_device_p2 = “257”

    As per astorek86’s post here:

    Multi tap support

    Adding that line did not enable multitap in any other snes cores on my system, even the other ones which start with lr_. I have searched through all of the configs and sparse documentation for the other cores to see if there is some way to enable multitap, but haven’t found anything.

    I’ve used rom editing software to try adding/removing headers, applying general ‘fixes’, overdump trimming, etc etc, I’ve had SB5 and SB4 rom files on the operating table for about 2 hours, but nothing helped. These games were never released outside of Japan, and perhaps use some special internals. All the other cores can run them though, and so can every x86 version of ZSNES and Snes9x that I ever used on Windows. I tried using DOS ZSNES through DOSBox on RetroPie, but it ran the game too slow to be playable, no surprise. I’ve also tried many different versions of the roms, in case some were damaged or corrupt or something. But again, they do run great on other SNES cores.

    At this point it seems like getting multitap to work on a core other than snes9x is my best bet. It seems that several Japan Only Bomberman games have quirks, as per the changelog for CATSFC:

    – Panic Bomberman World requires SPC700 memory to be initialised to zero on
    reset otherwise the game hangs when a tune finishes and another one should

    – Panic Bomber World, Bomberman 4 and UFO Kamen Yakisoban all need the slower
    SPC700 timing.


    I do not have any error logs or crash dumps from Snes9x, because I don’t know where they are or how to access them. I’ve looked for this info but haven’t found it. If anyone can help me locate this info, I would be happy to post it, but at this point it may be easier to find a way to get multitap working on other SNES cores.

    Thanks for reading, and any ideas you have!

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.