Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • pattaboy
    Participant
    Post count: 44

    I think it will be handy to enable or disable analog sticks for psx emulators within retropie-setup.

    Right now in 3.0 I have problems setting them up.
    Normally I only had to configure retro-arch-coreoptions and then it works.
    right now they don’t. still haven’t figured it out

    padraigdoran
    Participant
    Post count: 3

    I’m on 3 rc 1 and the analogue sticks don’t work anywhere in emulationstation. It’s strange though, they did get picked up when initially configuring the gamepads.

    padraigdoran
    Participant
    Post count: 3

    After reading around and doing some testing based on what I read, I did the following to get them working:

    Edit this file:
    /opt/retropie/configs/all/retroarch.cfg

    Set
    input_libretro_device_p1 = “5”
    where p1 above is the player number, like p1, p2, etc

    and set
    input_player1_analog_dpad_mode = “1”
    for each player also.

    Restart and that will allow the analog sticks to work in the games. It doesn’t work in emulationstation for some reason but that is not such a big deal.

    smaikel
    Participant
    Post count: 9

    Yes! this is working. But I would like to know what is

    input_player1_analog_dpad_mode = “1”

    corresponding to in RGUI.

    Anonymous
    Inactive
    Post count: 94

    Will doing this disable the dpad?

    tandreasen
    Participant
    Post count: 1

    where can i find input_player1_analog_dpad_mode…`?

    dlux
    Participant
    Post count: 2

    analog sticks working, but not in an analog fashion..

    as per padraigdoran, when i Edit this file:
    /opt/retropie/configs/all/retroarch.cfg

    and i set:
    input_libretro_device_p1 = “5”

    and i add:
    input_player1_analog_dpad_mode = “1”

    after restarting emulationstation, the sticks work, but they’re digital; i.e. in driver 2 and gran turismo 2, both games that really oughtta support the analog sticks, you’re either turning hard or going straight.. there’s no turning slightly/gently vs. a hard turn (analog action)..

    looking for further advice…

    dlux
    Participant
    Post count: 2

    and no, doing this does not disable the dpad.

    eyepie
    Participant
    Post count: 2

    I’m in the same boat, I managed to get the analog sticks to ‘work’… but only with digital functionality. I can’t seem to figure out how to make them actually function as analog sticks.

    flowlance
    Participant
    Post count: 4

    Any news to this? I’m using a NES30 Pro controller and the analog sticks are digital on the psx emulator, either on or off. Nothing in between. They work on the n64 emulator though.

    flowlance
    Participant
    Post count: 4

    After googling to the end of the universe and back, i found a solution that worked for me.

    Make these changes

    pcsx_rearmed_pad1type = "analog"
    pcsx_rearmed_pad2type = "analog"

    to

    /opt/retropie/configs/all/retroarch-core-options.cfg

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘Ideas for Further Enhancements’ is closed to new topics and replies.