Viewing 26 posts - 1 through 26 (of 26 total)
  • Author
    Posts
  • Swampy
    Participant
    Post count: 16

    I’m using a Raspberry Pi 2 with Composite Video and an old TV. After I updated the RetroPie Script and the emulators (3.0 -> 3.1), the Emulationstation screen is too big for the TV. The screen is OK for the emulators and for the boot-process. Only Emulationstation don’t fit.
    Is it possible, that a kernel-update was the problem?
    Is it also possible, that I can change the dimensions only for the Emulationstation-screen?
    Any other experiences with composite-video?

    Thanks in advance and sorry for my bad English.

    [attachment file=”config.txt”]

    petrockblog
    Keymaster
    Post count: 1827

    I believe it is related to a firmware/kernel update as someone else had the problems too.

    you can use rpi-update to roll back firmware and find out when it breaks – backup your system first etc.

    https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=19415 has some basic instructions on how to do this.

    if we can pin it down to a specific update we can report it back to rpi firmware github.

    petrockblog
    Keymaster
    Post count: 1827

    At least it would help confirm if it is firmware or something else config wise which has changed.

    Swampy
    Participant
    Post count: 16

    Thank you for your fast post. One additional question:
    What was the firmware/kernel-version of Retropie 3.0?
    It would be easier to test, if I have a specific timeline.
    Then I can reply from which version the problem appears.

    shoothere
    Participant
    Post count: 131

    Hi Swampy,

    I made a thread with what seems to be the same problem.

    I went all the way down to 3.18.16 and the problem persisted.

    Which emulators have you tried? The GBA one goes offscreen for me.

    Perhaps it doesn’t matter but what kind of TV do you have? We have a Panasonic Plasma.

    Swampy
    Participant
    Post count: 16

    OK, just tried kernel: Bump to 3.18.10 -> works
    kernel: Bump to 3.18.16 -> Don’t work
    kernel: Bump to 3.18.14 -> Don’t work
    kernel: Bump to 4.0.5 -> Don’t work

    Bump to 3.18.10: sudo rpi-update 8751db9fd7138848c29cc55ec05f95c9eea80acb

    My TV: Panasonic TBM8E2145 (CRT)

    Swampy
    Participant
    Post count: 16

    OK, just tried kernel: Bump to 3.18.12 -> works too

    Bump to 3.18.12: sudo rpi-update 2f4703cbee9801ef04adcf63d74823961cc3c275

    The problem must be somewhere between kernel 3.18.12 and kernel 3.18.14.
    I will test them too!

    For now the screen-problems disappeared with kernel 3.18.12

    shoothere
    Participant
    Post count: 131

    I can confirm going all the way down to 3.18.12 fixed it for me too.

    petrockblog
    Keymaster
    Post count: 1827

    Please work out which commit the behaviour changed and then open a ticket on https://github.com/raspberrypi/firmware with details of the last commit it worked, the one where it broke, and your config.txt (which really just has the overscan_scale=1 set which is related)

    petrockblog
    Keymaster
    Post count: 1827

    It may be something they changed intentionally, but it will help me to know what we need to change our end.

    Swampy
    Participant
    Post count: 16

    OK, i will check that in the next days and post it. I never opened a ticket on github. I hope I will manage this.

    Thanks for your help!

    Swampy
    Participant
    Post count: 16

    kernel: Bump to 3.18.13 (Commits on May 9, 2015) is the last which works good.
    With firmware: video_render: Use crop rectangles rather than port parameters to handle opaque images (Commits on May 13, 2015) the problem appears.

    Last working:
    https://github.com/Hexxeh/rpi-firmware/commit/8521fd34c8f66b6d109acce943f6e25ec93ec005
    First not working:
    https://github.com/Hexxeh/rpi-firmware/commit/03b44377dd1f410900d93ca92d39cdacba3544ac

    Swampy
    Participant
    Post count: 16

    I opened a ticket on https://github.com/raspberrypi/firmware and I hope I described the problem correct.

    petrockblog
    Keymaster
    Post count: 1827

    Looks good thanks. Let’s see what they say.

    shoothere
    Participant
    Post count: 131

    Would further input from me on the ticket/issue help?

    petrockblog
    Keymaster
    Post count: 1827

    Well yes because they asked you a question, but I have answered it for you :)

    petrockblog
    Keymaster
    Post count: 1827

    Aah sorry I have got mixed up – you could mention it affects you too I guess – sorry!

    smartroad
    Participant
    Post count: 76

    I have the same issue, it is like EmuStat isn’t honouring the overscan settings?

    petrockblog
    Keymaster
    Post count: 1827
    Swampy
    Participant
    Post count: 16

    I always used a retropie-image. I think popcornmix (https://github.com/raspberrypi/firmware/issues/484) has builded emulationstation from source. Is there anybody, who might help popcornmix to reach the main menu.

    Swampy
    Participant
    Post count: 16

    I have tested the testbuild https://dl.dropboxusercontent.com/u/3669512/temp/firmware_scale.zip and it solves the problem for me. I only have tested emulationstation, not the emulators. Perhaps, somebody of you would like to do this.

    shoothere
    Participant
    Post count: 131

    Willing to test but does one use the rpi-update tool for this?

    Swampy
    Participant
    Post count: 16

    Willing to test but does one use the rpi-update tool for this?

    First you have to update with sudo rpi-update. I think that is not necessary, but I have done that, to get the latest firmware and kernel. Then you must download the testbuild https://dl.dropboxusercontent.com/u/3669512/temp/firmware_scale.zip. You have to unzip the file and copy the included files to the /boot directory of your retropie-image. The old files must be overwritten. If popcornmix will include this in the next version of the firmware, you only have to do sudo rpi-update.

    Swampy
    Participant
    Post count: 16

    popcornmix has fixed the problem. Thank you all for helping me.
    A sudo rpi-update will do it now!

    shoothere
    Participant
    Post count: 131

    I can confirm the issue is resolved for me too!

    artwebb1986
    Participant
    Post count: 3

    I did a sudo rpi-update it put me to 4.1.13-v7+ and the “Start” Menu “A” Select are still off the bottom/left of the screen about half way. I did the overscan in the config.txt and that didnt do anything at all either. I set the HDMI mode to 720p as well and same thing.

    FIXED: added overscan_scale=1 to my config.txt and all is well now.

Viewing 26 posts - 1 through 26 (of 26 total)
  • The forum ‘Video Output on RetroPie’ is closed to new topics and replies.