Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • eloquentmess
    Participant
    Post count: 3

    I’m loving the RetroPie project so far! I’ve only had one major problem that I can’t seem to fix, and that’s getting Duke Nukem 3D to work.

    I saw in another thread that someone managed to get it up and running by installing eduke32 from source using the retropie-setup.sh script, so I went ahead and followed those instructions, but I still can’t seem to get it running!

    I get the following error when I try to run the program:

    eduke32: error while loading shared libraries: /usr/lib/arm-linux-gnucabihf/libvorbisfile.so.3: invalid ELF header

    I’m not sure what I can do about this. Should I uninstall and reinstall the libvorbisfile3 library? What are my options?

    eloquentmess
    Participant
    Post count: 3

    Sorry, I mis-typed the error. Here’s the proper version:

    eduke32: error while loading shared libraries: /usr/lib/arm-linux- gnueabihf/libvorbisfile.so.3: invalid ELF header

    eloquentmess
    Participant
    Post count: 3

    I fixed the problem, kind of.

    I tried to remove and re-install the required components, but it ended up breaking the system.

    So I downloaded a fresh Raspbian image, wrote it to the SD card, and started from scratch. From the Raspbian image, I followed the instructions here and installed the entire system from source, setting everything up exactly as I needed it to be.

    The only thing that didn’t cleanly install was the PPSSPP emulator.

    I was able to get eduke32 running, though I couldn’t get my 360 controller to work with it, and it wouldn’t grab the mouse, so I couldn’t use the mouse to control the game. (The mouse pointer simply moved around independently of the game.)

    Regardless, it’s a big first step, and I’m sure we can figure out the other problems.

    petrockblog
    Keymaster
    Post count: 1827

    PPSSPP makes problems in these days. If someone finds a solution for how to compile it, feel free to post it here o at Github!

    rolsch
    Participant
    Post count: 5

    I had the same problem and I read somewhere the following solution:
    Problem is that the file is a regular file but it should be a link to /usr/lib/arm-linux-gnueabihf/libvorbisfile.so.3.3.4 so this can be fixed by

    
    cd /usr/lib/arm-linux-gnueabihf
    rm libvorbisfile.so.3
    ln -s libvorbisfile.so.3.3.4 libvorbisfile.so.3
    
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.