Viewing 1 post (of 1 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 1

    By default none of these controller’s dpad worked in SNES, Genesis, or MAME however it worked fine for retropie menu. Which means the hardware is working but I’m guessing the control mapping is screwed up somewhere.

    I edited: /opt/retropie/configs/all/retroarch-joypads/MicrosoftX-BoxOnepad.cfg
    because the “_btn” suffix is missing on the dpad parts of the config file as another user had pointed out. After that the dpad worked in gensis but not MAME. However the analog was working in MAME.

    I tried deleting config files and re-running retropie setup control config but it didn’t help. Am I supposed to set up a config file for each system I want to use? If so, how do I make a config file for an individual game system?

    I read several guides but I guess they’re for previous versions (I’m new to retropie).

    What I’m using:
    Raspberry Pi 2 Model B w/2.5A power supply
    RetroPie 3.0 beta 4
    Xbox one controller (connected w/usb cable)
    PS4 (connected w/usb cable)
    Xbox 360 (wireless connected using included xbox 360 dongle and installed retropie driver)
    Using Powered USB

    Thanks!

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.