Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • retrocam
    Participant
    Post count: 16

    Hi everyone. I’m slowly adding systems to my RetroPie setup. Such a great project! I have run into a hitch with DosBox (which runs games incredibly well on the Pi2!)

    If I use the +Start DOSBOX script included when I installed it, it runs fine, and exits fine. Even if I load a game by manually mounting and running the .exe it works fine and exits fine back to emulationstation.

    Now I am trying to create scripts to load the games automatically. If I create a script, for example skyroads.sh:
    /opt/retropie/emulators/dosbox/bin/dosbox -c "mount c /home/pi/RetroPie/roms/pc/Skyroads" -c "c:" -c "skyroads.exe" -c exit
    It appears in emulation station and when you run it it just opens dosbox (seems the start dosbox script takes over.

    I then changed es.systems.cfg:
    from:

    <system>
        <fullname>PC (x86)</fullname>
        <name>pc</name>
        <path>~/RetroPie/roms/pc</path>
        <extension>.sh .bat .BAT .exe .EXE</extension>
        <command>/home/pi/RetroPie/roms/pc/+Start\ DOSBox.sh %ROM%</command> 
        <platform>pc</platform>
        <theme>pc</theme>
     </system>

    to:

    <system>
        <fullname>PC (x86)</fullname>
        <name>pc</name>
        <path>~/RetroPie/roms/pc</path>
        <extension>.sh .bat .BAT .exe .EXE</extension>
        <command>%ROM%</command>
        <platform>pc</platform>
        <theme>pc</theme>
      </system>

    Now when I select the game, it does run the script, and the game runs fine, but when you exit the game it crashes the Pi, it goes to a black screen and I lose all control, can’t SSH in etc. It isn’t the game itself because I have tried with another game, and if I remove the “exit” command from the script, it stays in DosBox fine until I exit and it should go back to emulationstaion. Also the same game runs fine if I run my skyroads.sh outside emulationstation.

    Any ideas would be greatly appreciated. :)

    dudleydes
    Participant
    Post count: 139

    With your current config, the framebuffer is left in an unusable state when you exit DosBox. To fix, add runcommand.sh to your es.systems.cfg so the <command> tag now reads:

    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 "%ROM%"</command>
    More info at Run DOS games in Retropie

    retrocam
    Participant
    Post count: 16

    [quote=92155]With your current config, the framebuffer is left in an unusable state when you exit DosBox. To fix, add runcommand.sh to your es.systems.cfg so the <command> tag now reads:

    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 "%ROM%"</command>
    More info at Run DOS games in Retropie
    [/quote]

    Thanks so much dudleydes! That did the trick. I read your blog about setting it up but I must have missed that bit.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.