Tagged: 

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 1

    Hi all,

    After following the guide at http://lifehacker.com/how-to-turn-your-raspberry-pi-into-a-retro-game-console-498561192 I’m having issues when loading ROMs on the Mega Drive emulator.

    Following is my Hardware, using RetroPie image 1.5
    512mb Pi
    1A DC adapter
    8GB SD Card
    2 USB Controllers

    I have tried 3 ROMs, Sonic 1, 2 and World Of Illusion – though they all have the same issue: I get the DGEN splash screen, and my Pi simply hangs…

    I have removed one of the controllers, to see if it’s power related, but no joy.

    Any help greatfully recieved!

    Idris_Arslanian
    Participant
    Post count: 21

    What does your DGENRC file look like? Also please include the DGEN section from your .emulationstation/es_systems.cfg file.

    anakaine
    Participant
    Post count: 11

    Hi,

    I am having exactly the same issue. Emulator hangs on the DGEN splash screen. I have the same config as the opening poster (perhaps the controllers are a different brand :p) If it helps, we’re using the RetroPie v1.6 Beta disk image. NES is successfully working with two usb snes style controllers.

    DGENRC: /home/pi/RetroPie/emulators/dgen-sdl contains “sample.dgenrc”. Is there a mthod for setting up DGEN separately that could be causing the hang?

    Alternatively in .dgenrc there is a DGENRC file that contains two commented out lines, and the additional dgenrc.auto file that looks like:

    # DGen/SDL v1.32
    # This file is automatically overwritten.
    
    key_pad1_up = "UP"
    joy_pad1_up = "joystick0-axis1-min"
    key_pad1_down = "DOWN"
    joy_pad1_down = "joystick0-axis1-max"
    key_pad1_left = "LEFT"
    joy_pad1_left = "joystick0-axis0-min"
    key_pad1_right = "RIGHT"
    joy_pad1_right = "joystick0-axis0-max"
    key_pad1_a = "a"
    joy_pad1_a = "joystick0-button0"
    key_pad1_b = "s"
    joy_pad1_b = "joystick0-button1"
    key_pad1_c = "d"
    joy_pad1_c = "joystick0-button2"
    key_pad1_x = "q"
    joy_pad1_x = "joystick0-button3"
    key_pad1_y = "w"
    joy_pad1_y = "joystick0-button4"
    key_pad1_z = "e"
    joy_pad1_z = "joystick0-button5"
    key_pad1_mode = "BACKSPACE"
    joy_pad1_mode = "joystick0-button6"
    key_pad1_start = "RETURN"
    joy_pad1_start = "joystick0-button7"
    key_pad2_up = "KP_8"
    joy_pad2_up = "joystick1-axis1-min"
    key_pad2_down = "KP_2"
    joy_pad2_down = "joystick1-axis1-max"
    key_pad2_left = "KP_4"
    joy_pad2_left = "joystick1-axis0-min"
    key_pad2_right = "KP_6"
    joy_pad2_right = "joystick1-axis0-max"
    key_pad2_a = "DELETE"
    joy_pad2_a = "joystick1-button0"
    key_pad2_b = "END"
    joy_pad2_b = "joystick1-button1"
    key_pad2_c = "PAGE_DOWN"
    joy_pad2_c = "joystick1-button2"
    key_pad2_x = "INSERT"
    joy_pad2_x = "joystick1-button3"
    key_pad2_y = "HOME"
    joy_pad2_y = "joystick1-button4"
    key_pad2_z = "PAGE_UP"
    joy_pad2_z = "joystick1-button5"
    key_pad2_mode = "KP_PLUS"
    joy_pad2_mode = "joystick1-button6"
    key_pad2_start = "KP_ENTER"
    joy_pad2_start = "joystick1-button7"
    key_fix_checksum = "F1"
    joy_fix_checksum = ''
    key_quit = "ESCAPE"
    joy_quit = ''
    key_craptv_toggle = "F5"
    joy_craptv_toggle = ''
    key_scaling_toggle = "F6"
    joy_scaling_toggle = ''
    key_screenshot = "F12"
    joy_screenshot = ''
    key_reset = "TAB"
    joy_reset = ''
    key_slot_0 = "0"
    joy_slot_0 = ''
    key_slot_1 = "1"
    joy_slot_1 = ''
    key_slot_2 = "2"
    joy_slot_2 = ''
    key_slot_3 = "3"
    joy_slot_3 = ''
    key_slot_4 = "4"
    joy_slot_4 = ''
    key_slot_5 = "5"
    joy_slot_5 = ''
    key_slot_6 = "6"
    joy_slot_6 = ''
    key_slot_7 = "7"
    joy_slot_7 = ''
    key_slot_8 = "8"
    joy_slot_8 = ''
    key_slot_9 = "9"
    joy_slot_9 = ''
    key_save = "F2"
    joy_save = ''
    key_load = "F3"
    joy_load = ''
    key_z80_toggle = "F10"
    joy_z80_toggle = ''
    key_cpu_toggle = "F11"
    joy_cpu_toggle = ''
    key_stop = "z"
    joy_stop = ''
    key_game_genie = "F9"
    joy_game_genie = ''
    key_fullscreen_toggle = "alt-RETURN"
    joy_fullscreen_toggle = ''
    key_debug_enter = "


    joy_debug_enter = ”
    key_prompt = “:”
    joy_prompt = ”
    bool_vdp_hide_plane_a = false
    bool_vdp_hide_plane_b = false
    bool_vdp_hide_plane_w = false
    bool_vdp_hide_sprites = false
    bool_vdp_sprites_boxing = false
    int_vdp_sprites_boxing_fg = 16776960
    int_vdp_sprites_boxing_bg = 65280
    bool_autoload = false
    bool_autosave = false
    bool_autoconf = true
    bool_frameskip = true
    bool_show_carthead = false
    str_rom_path = “roms”
    bool_raw_screenshots = false
    ctv_craptv_startup = off
    scaling_startup = default
    emu_z80_startup = cz80
    emu_m68k_startup = musa
    bool_sound = true
    int_soundrate = 22050
    int_soundsegs = 8
    int_soundsamples = 0
    int_volume = 100
    key_volume_inc = “=”
    joy_volume_inc = ”
    key_volume_dec = “-”
    joy_volume_dec = ”
    bool_mjazz = false
    int_nice = 0
    int_hz = 50
    bool_pal = true
    region = ‘ ‘
    str_region_order = “JUEX”
    bool_fps = false
    bool_buttons = false
    bool_fullscreen = false
    int_info_height = -1
    int_width = -1
    int_height = -1
    int_scale = -1
    int_scale_x = -1
    int_scale_y = -1
    int_depth = 0
    bool_swab = false
    bool_opengl = true
    bool_opengl_aspect = true
    int_opengl_width = -1
    int_opengl_height = -1
    bool_opengl_linear = true
    bool_opengl_32bit = true
    bool_opengl_swap = false
    bool_opengl_square = false
    bool_doublebuffer = true
    bool_screen_thread = false
    bool_joystick = true

    
    
    The .emulationstation/es_systems.cfg fragment for mega drive looks like
    
    

    DESCNAME=Sega Mega Drive / Genesis
    NAME=megadrive
    PATH=/home/pi/RetroPie/roms/megadrive
    EXTENSION=.smd .SMD .md .MD .bin .BIN .zip .ZIP .gz .GZ .bz2 .BZ2
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 “/home/pi/RetroPie/emulators/dgen-sdl/dgen -f -r /home/pi/RetroPie/configs/all/dgenrc %ROM%”
    # alternatively: COMMAND=export LD_LIBRARY_PATH=”/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs”; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%
    PLATFORMID=18`

    Thank you very much for your help. I know we’re pretty keen to get sonic cranked up over here :)

    anakaine
    Participant
    Post count: 11

    As we can see, I’m brilliant at opening and closing code tags. Sorry.

    anakaine
    Participant
    Post count: 11

    Just updated to the most recent image 1.6.1. The same problem with hanging still exists.

    karloss
    Participant
    Post count: 177

    Maybe have a try running the RetroPie script and doing a source install of DGEN see if it fixes it? I used 1.5 with as a base and have done a couple of updates this wa and all seems to be working fine…

    going to try the 1.6.1 base tonight

    anakaine
    Participant
    Post count: 11

    Righto…

    So I built 1.6.1 from sources, still no go with DGEN.

    So I’ve now tried roms from 3 different sources, both inside of their zip files (per rom), and as an extracted smd file. Nothing seems to work, still hanging at the DGEN splash screen.

    That said, I tried some master systems roms (sms) tonight too, and they don’t seem to work either, with osmose hanging at ablack screen.

    Might give the retropie image 1.5 image a shot.

    karloss
    Participant
    Post count: 177

    your not by anychance using composite output and haven’t made the changes to get video by changing the runcommands to a 2 instead of 1? also dgen doesn’t work over composite..

    anakaine
    Participant
    Post count: 11

    NO, I’m using HDMI.

    I’m also downloading the 1.5 image at the moment to see if it will make a difference. Fingers crossed!

    nicosuave214
    Participant
    Post count: 3

    i also did the lifehacker project like you guys but for me it will only show atari roms even though i have many more loaded on it, and my controllers are not recognized in the ROMs. If you guys have any idea how to fix this please let me know.

    karloss
    Participant
    Post count: 177

    burnt the 1.6.1 image to sdcard last night, added streets of rage 2 rom, and worked with dgen no issues atall, over hdmi, composite still doesn’t work ;(

    petrockblog
    Keymaster
    Post count: 1828

    [quote=2193]burnt the 1.6.1 image to sdcard last night, added streets of rage 2 rom, and worked with dgen no issues atall, over hdmi, composite still doesn’t work ;([/quote]
    Did you enable Dispmanx for DGEN? It comes precompiled with 1.6.1, but it is not enabled in the es_systems.cfg.

    anakaine
    Participant
    Post count: 11

    For me, the fix was:

    Using the 1.5 disk image
    Ensuring that my roms are in the SMD format, and not the bin format. <– realistically this was probably the fix the entire time. I used a program called SBWin to convert between bin, md and SMD. Beware however, this program comes loaded with adware crap that you will either need to not install, or uninstall later. I seriously recommend sandboxing this when and installing. Seriously.

    Since I’m pretty n00b, I’m not too sure how to go about running Dispmanx, configuring, etc. So it is potentially better to not have to worry about it in this instance.

    marador
    Participant
    Post count: 6

    Sabe bug

    I install dispmanx and changing the runcommands to a 2 instead of 1.

    I do not understand why in the retropie image not run wheels, it s supuse to run without touch nothing..

    anakaine
    Participant
    Post count: 11

    marador: Are you using HDMI or composite video?

    No one system can cope with every type of setup. I am relatively confident that using the setup I have described above (default settings for 1.5 / 1.6 / 1.6.1) and the rom set in the appropriate format that everything will work on HDMI

    marador
    Participant
    Post count: 6

    Composite

    anakaine
    Participant
    Post count: 11

    You do realise that the reason you are having issues with composite is because the Rpi is designed to use HDMI primarily, and composite is a backup. So out of the box, Rpi software is typically HDMI enabled. Retropie is built on top of the raspian release wheezy, and thus also is designed around HDMI first and foremost.

    It’s fine to ask how to change it, it’s not fine to whinge about it not working when the system is designed around another output primarily. This is why you needed to change the setting – because you are implementing a non standard system.

    petrockblog
    Keymaster
    Post count: 1828

    In the best case the RetroPie installation works for both video outputs. The problem is that I cannot test the composite output and anyone has posted a pull request for the RetroPie Script at https://github.com/retropie/RetroPie-Setup/issues?state=open that is supposed to solve this issue. Posting such things at the Github repository is essential for that.

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.