Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • kmhamel
    Post count: 50

    Well so far so good.

    I have one usb encoder and two ps3 controllers.
    I have mame and psx setup and running. now I’m working on N64.

    I found that if you are using retroarch and don’t want the encoder to play a part as a controller you just set your ps3 controllers in the confings for retropie.

    now how do I set mupen to only use the ps3 controllers. It auto detects all three joypads js0=encoder, js1=ps3, js2=ps3. I see in the config file all three are setup and ready for use. Is there a way to disallow the encoder?

    Post count: 42

    Ok, so I am guessing you are looking in mupen64plus.cfg like here:

    See where it says mode = 2, you want to set your mode to 1 or 0.
    Mode 1 pulls key settings from InputAutoCfg.ini, and mode 0 uses whatever keys you set in mupen64plus.cfg.
    I prefer mode 1 so will recommend setting it to 1 for player 1 and 2, typing the name of your controller as it appears in InputAutoConfig.ini (which I am guessing is ‘Sony Playstation(R)3 Controller’ just like the video), and setting up your keys up in the InputAutoCfg.ini file.

    For player 3 and 4, just set the mode to 0 and delete the name, or set it to something else other than the name of your encoder, then only your ps3 controllers will be picked up!

    Hope this helps, let me know if not.

    Post count: 50

    Finely got a chance to try out the setting. Mupen still sees the encoder as a joypad even with the mode set to 0 and a name change in mupen64plus.cfg. With the encoder taking up the js0 spot, the playstation controllers take js1 and js2 the games see js0 as the first joypad. I just might have to wait for the controller block to start selling again.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.