Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • scrapz
    Post count: 2

    Hi guys,

    Just set up my Raspberry Pi using the RetroPie SD image, and I’m having an issue with just the one game. With Super Mario Brothers All Stars, I can browse the games just fine with my USB controller, I can select and start the game just fine past the specific game screen (ie: if I load up SMB3, I can start and choose number of players), but once it takes me into the game, the controller becomes completely unresponsive. This happens with any game in All Stars. Every other game I throw at it works fine.

    Any clues as to what’s going on here? SMB is really important to me :(

    Post count: 207

    This is a known problem will ALL Super Mario All-Stars roms. There’s no known fix and it happens with every emulator. Sorry.

    Sent from my GT-I9300 using Tapatalk

    Post count: 2

    Ah, poop. So this is only an issue with emulators on the RaspberryPi?

    Post count: 207

    It seems so yes. If you try other games they work fine it’s just this rom. It must be something to do with the emulators.

    Sent from my GT-I9300 using Tapatalk

    Post count: 2


    I solved this strange player swaping issue by manually correcting the values of the input_player2_joypad_index in file RetroPie/configs/all/retroarch.cfg.
    This value could be incorrectly set in particular if you use RGUI to configure your pads.

    You should ensure that no joypad has the same index, and particularly for player1 and player2.

    Wrong settings:

    input_player1_joypad_index = "0"
    input_player2_joypad_index = "0"

    Good settings:

    input_player1_joypad_index = "0"
    input_player2_joypad_index = "1"

    Hopes that helps,


    Post count: 207

    The above doesn’t really fix the problem. I’ve made sure both pads are set to “1” and “0” and I still get non responsive controls when the game starts.

    Post count: 571

    you need both controllers set to 0, I’m sure that’s what I have set, I’ll double check when I get home

    Post count: 207

    I did set both player inputs to “0” but this breaks Mario Kart! I managed to fix this by completely disabling player 2 input and changing the “1” to “nul”.

    Post count: 908

    Good evening all,

    Did someone found a solution for SM all Stars games? same issue here. But what is strange i played it for the first time at a friend house yesterday and it worked fine… today mario isn’t moving… any clue guys?

    Post count: 17

    I got the game working, the only issue is that when thou start the game, it (the game) swap the controllers (P1 becomes P2 and vice-versa).

    So what you need to do is play with controller #2

    Post count: 1

    Doing a ton of work on swapping out PiSnes and RetroArch and have had issues with both. It looks like in PiSnes, some of the games will load and some will not so it is not very usable IMO.

    So RetroArch is your best option but has no one found a FIX yet for the Player1 and Player2 swapping? I am guessing the only way you can play with you friends is to have 2 controllers configured.

    I do not want to map both indexes to 0 because that will break player 2 controls for other games.

    If there any fix yet?

    Post count: 65

    booo anyone :(

    Post count: 3

    I can confirm as I changed my pads


    input_player1_joypad_index = “0”
    input_player2_joypad_index = “0”


    input_player1_joypad_index = “0”
    input_player2_joypad_index = “1”

    and I couldnt play Mario All Stars anymore.

    However playing on with
    input_player1_joypad_index = “0”
    input_player2_joypad_index = “0”

    also has an issue if I press stat to pause Streets Of Rage it adds a two player in lol as well as not allowing me to play mario kart anymore

    any other possible fixs?

    Post count: 1

    I am a newbie to retropie but I guess I am lucky enough to have SMB and SMK working without doing anything special.

    However at first it did not work as mention in this post. I could navigate in the menu of SMB but when the controller froze once in the game (in the map land). This only happens if I have only one controller connected.

    My configuration is a B+ with 2 identical USB gamepads connected to the Pie.

    First I run the calibration from retropie-setup with only one controller connected. It created a new configuration file called “GreenAsiaInc.USBJoystick.cfg”, here is the content :

    input_device = “GreenAsia Inc. USB Joystick ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “9”
    input_start_btn = “8”
    input_up_btn = “h0up”
    input_down_btn = “h0down”
    input_left_btn = “h0left”
    input_right_btn = “h0right”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_l2_btn = “6”
    input_r2_btn = “7”
    input_l_x_plus_axis = “+0”
    input_l_x_minus_axis = “-0”
    input_l_y_plus_axis = “+1”
    input_l_y_minus_axis = “-1”
    input_r_x_plus_axis = “+2”
    input_r_x_minus_axis = “-2”
    input_r_y_plus_axis = “+3”
    input_r_y_minus_axis = “-3”

    Then I connect the second controller and it worked, I have verified with 1 player and 2 players and it worked. Then I have tried SMK 1/2 players and it also worked. Maybe the key is to have two identical controllers connected?

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.