Homepage Forums RetroPie Project Everything else related to the RetroPie Project Controller setup emulationstation vs emulators

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3864

    Im using version 1.9.1 of RetroPie and a “Mega World USB Game Controllers” (ID 07b5:0314).

    In the menue the controller works instantly. After runnig the graphical “Input Configuration” for “RetroArc” the config under ~/RetroPie/configs/all/retroarch.cfg looks like this:

    input_player1_joypad_index = 0
    input_player1_b_btn = 2
    input_player1_a_btn = 3
    input_player1_y_btn = 0
    input_player1_x_btn = 1
    input_player1_l_btn = 4
    input_player1_r_btn = 6
    input_player1_start_btn = 9
    input_player1_select_btn = 8
    input_player1_up_btn = h0up
    input_player1_down_btn = h0down
    input_player1_left_btn = h0left
    input_player1_right_btn = h0right

    It seems to be OK, cause “jstest /dev/input/js0″ shows the same button-numbers and the “creation time” of the file is “now”.

    Then i run SNES or NES emulators with different ROMs and i’ve no buttons except “start”. I’ve already tried to copy the input config to the more specific configs like “~/RetroPie/configs/snes/retroarch.cfg”

    Any Ideas?


    You could try and follow the steps described in the post at https://www.petrockblock.com/2013/12/02/retropie-autoconfig-functionality/. Maybe that helps!?

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.