Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • benny
    Participant
    Post count: 1

    Hi everyone, I am brand new to all this and I don’t seem to be very good. I have gotten as far as to get a few games working but then my controls are all screwed up. I did the whole
    sudo chown pi /opt/retropie/configs/all/retroarch.cfg

    cd /opt/retropie/emulators/RetroArch/installdir/bin

    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    commands and then I get the controller all setup the way I want. Once I start my game “Super Mario World” for SNES, anytime I press down I jump, and left acts as the A button even though I set the controller correctly. Any suggestions on what I may be doing wrong? The videos I watch are confusing and I feel like I am doing something just slightly wrong. Thanks!

    Floob
    Member
    Post count: 1629

    I would really suggest not to follow those steps to get your controller configured – that would effectively hard code certain buttons in your main config – meaning the auto configuration which is set on by default would get overwritten.

    I would suggest using the RetroPie3 beta 2 image available here. Write that to your card and boot. Then quit out of Emulation Station and run the retropie setup script.
    This will let you run the controller config – very similar to this:

    http://dai.ly/x2hudzs

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.