Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • noxious
    Post count: 3


    I’ve set up my rpi with the gpio adapter and soldered it to one SNES connector. After a bit of struggling i finally realized I had to install the gamecon driver and it registered my controller when I ran jstest /dev/input/js0. However, I’m not exactly sure what the message means when it says:

    “Axes: 0:      0  1:      0: Buttons: 0:on 1:on 2:on 3:on 4:on 5:on 6:on 7:on”

    Does the “on” part mean that the button is pushed down? Because it’s not..

    Every 15 second it spams back and forth between on and off for a second and then stays at on.

    Also when I try to use retroarch-joyconfig and save it to retroarch.cfg file it registers ALL buttons when I press A (which is the first to be mapped) Anyone has any clue why this happens? I can’t seem to figure it out.

    best regards,

    Post count: 1827

    “On”means the systems recognizes these buttons as being pressed, which, as you described, is not correct.

    This could be a software (configuration) problem or a hardware problem (wrong pin assignments on the 2×5 pin connector).
    To see if this is a software issue I would suggest to test, if using SNESDev works better. For that you
    – first need to uninstall the gamecon driver.
    – Then you install SNESDev.
    Both steps can be done with the RetroPie Setup Script from within the “setup” menu. Just as the gamecon driver SNESDev emulates two game pad devices. The difference is that SNESDev does this in user space (opposed to kernel space). As with the gamecon driver you can use jstest to see if the OS recognizes your gameplay correctly.

    Post count: 3

    First off thanks for the fast reply!

    Second, I might not have stated it before but I am using thirdparty controller, and I only have recieved one of the extensioncables which means I only have one port out at the moment from the GPIO adapter. I am 99% sure I have soldered it to the data 1  (as described in your post on wordpress), which if I’m not wrong, is the controller port 1. I am also using a RPi rev 002.

    During the day I’ve tried using the SNESDev and actually it locates controller JS1 (which in my mind is controller 2) and it does respond when I’m pushing the buttons. However testing js0 also responds, but with the same error as above (on/off spam).

    Also you stated it is possible to uninstall the gamecon driver in the retropie setup, I have not found out how to do this when using option 3 in the installer at least. I removed the card and reinstalled it from another PC, haha :-)

    Anyways, is it possible that the on/off spam is caused of the extensioncable not being soldered to it/the controller is not plugged in to those cables?



Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.