Viewing 1 post (of 1 total)
  • Author
    Posts
  • pokeylop
    Participant
    Post count: 2

    Hi, everyone,

    I set up RetroPie very recently, and it’s been a pretty exciting first project for me so far. I’m using an XBox 360 wireless controller with the USB wireless adapter.

    I’ve been having issues after making edits to “etc/rc.local”. I kept getting error codes while booting, so to fix this, I added the following code before the config lines for each controller

    rmmod xpad
    xboxdrv --trigger-as-button [...]

    This got rid of the error codes, and I reconfigured my controller in EmulationStation, absolutely fine. But when I tried to configure the RetroArch controls via /opt/retropie/emulators/RetroArch/installdir/bin/retroarch-joyconfig, the script doesn’t register input from the controller. I tested the controller with jstest, and it registers all input correctly; EmulationStation registers it fine too.

    I tried configuring the controller via the in-ROM prompt (f1), and via retropie_setup.sh, but I just get the same result. I could configure it just fine before editing etc/rc.local, but the connection between the controller and wireless adapter sometimes failed before changing the code.

    Anyone know what I can do? Thanks in advance. :)

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.