Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • abejfehr
    Participant
    Post count: 1

    Hi guys,

    I’m having a little bit of trouble configuring my (very cheap) USB controllers to work with PocketSNES.

    First I’ll describe the behaviour I’m seeing:
    – both controllers work to navigate the main Emulation Station menu
    – I open Super Mario World and select 2-player
    – I play as player 1 with controller 1 fine until I die, then it loads the world screen
    – I then try to use controller 2 to move the character, but it fails
    – I can move the character with controller 1 to select a level
    – I try to play level with controller 1, but it fails
    – I can play the level using controller 2

    Other games have other problems, this one is the closest to working.

    I ran the retroarch-joyconfig tool to configure both controllers. I ran:
    retroarch-joyconfig -j 1 -p 1 >> /opt/retroarch/configs/all/retroarch.cfg
    retroarch-joyconfig -j 0 -p 2 >> /opt/retroarch/configs/all/retroarch.cfg

    I also tried setting the controls just by hitting F1 to get to the RGUI > Settings > Input settings, but that didn’t resolve anything.

    Is there something I’m missing? Thanks in advance

    Floob
    Member
    Post count: 1629

    I’d be tempted to put your retroarch.cfg back how it was and just use the autodetect method.
    I think it might be easier to debug if there are issues then.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.