Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Wysee
    Participant
    Post count: 7

    Okay, so, I’ve set up the RetroPie emulator on my Pi and I have it connected by HDMI to my 32″ TV.Now, the issue I’m having is as follows. Almost everything is crazy laggy. The only games I’ve managed to actually play are low-graphic NES games, such as Castlevania and Bomberman. SNES & GBA games for example, are completely unplayable.

    Worth noting, I am an amateur when it comes to Raspbian (And Linux in general) so some settings I may have done, might not have affected the rights things.
    I have my screen resolution to 680×480 (in /boot/config.txt)
    Medium OC.
    I use one Tomee SNES USB controller, and that works okay so far.

    So, any idea what this could be? Any other settings to make the games actually playable?

     

    Thank you!

    petrockblog
    Keymaster
    Post count: 1827

    Do you also observe this when the USB controller is not connected to the RPi?

    Wysee
    Participant
    Post count: 7

    I forgot to mention, I was also running a USB-hub, and removing it removed some of the lag. No lag is reduced without the controller.

    So, now some games are playable, although GBA games, and certain SNES games are still pretty much unplayable. Is there any settings one could do to reduce the lag?

    Anonymous
    Inactive
    Post count: 11

    What Raspberry Pi version do you have? The A or B?  I have no lag with SMW, but the GBA lags for me too. I have the B version with 512Mb RAM. There could be a gaming edition of Raspberry Pi.

    Wysee
    Participant
    Post count: 7

    I’m running the B version (newest), with 512MB, and I still have the lag.

    Could it be that x is running too? Is there a way to test it without running x? As I’ve heard this is possible.

    floba
    Participant
    Post count: 1

    got the same problem with vba-next,

    but playing around with the “e” of the keyboard (slow motion) it toggles to real speed

     

    can you reproduce it?

     

    there are several problems with the sound, too, by pressing “e” it changed to slow motion speed, but with the right music, and by not pressing “e” the music is too ‘fast’

    is there a fix for this strange behaviour?

    skater_j10
    Participant
    Post count: 16

    @Wysee Are you overclocked to 900MHz (you might still be at 700MHz) and what’s your memory split like? 256? Do you have a heatsink on the CPU?

    Change your Pi hardware options with “sudo raspi-config”.

     

    Wysee
    Participant
    Post count: 7

    @Floba – I’ll give that a try when I can!

    @skater_j10 – I’m not sure, I clicked the Medium OC, and I have the default memory split. No heatsink, which is why I didn’t want to go over medium.

    Do I change the memory split in the raspi-config as well?

    skater_j10
    Participant
    Post count: 16

    Yep, memory split is configured in raspi-config, default for the RetroPie Image seems to be 128 but if you have a 512MB Pi some have recommended 256 memory split.

    Wysee
    Participant
    Post count: 7

    Okay .. I’ve ran into some other issues.

    As I have two SNES USB controllers, I decided to add another controller in the config, so far so good.
    At the same time, I followed this guide:

    gzz wrote:And I saw on the wiki that people wanted to start emulationstation at startup, all Ive done is add to .bashrc

    EMU=’emulationstation’

    if ps ax | grep -v grep | grep $EMU > /dev/null
    then
    echo “already running”
    else
    echo “starting up emulationstation”
    /home/pi/RetroPie/EmulationStation/emulationstation
    fi

    and in /etc/inittab

    replace
    1:2345:respawn:/sbin/getty –noclear 38400 tty1
    with
    c1:2345:respawn:/sbin/agetty -a pi -8 -s 38400 tty1 linux

    In order to get my EmulationStation to launch at start-up, as I didn’t check this option in the initial setup (Not even sure it was there?).
    Either way, now, I get this big wall of text in the beginning, and then, as it looks like it starts to boot into X, small dots show up, and the entire screen freeze in a glitched state, with wavy lines all over. Although, I can kinda make out the default Raspberry Pi wallpaper in the background.

    Now, as I’m really new to linux overall, is there any way to fix this? I mean, I really want it to boot into EmulationStation to begin with, but in this “torn” screen state I can’t do anything at all (Not even CTRL-ALT-BACKSPACE works).

    Wysee
    Participant
    Post count: 7

    Add: And just noticed, this path: /home/pi/RetroPie/EmulationStation/emulationstation, is wrong .. Could that do it?
    My first thought was that I had it set to ignore the password/user in the boot screen, and just jump straight into x, could that conflict with the autostart?

    Wysee
    Participant
    Post count: 7

    Add 2: The keyboard responded in one of those glitched-screen-states (for some reason) and I could boot into another user with CTRL-ALT-BACKSPACE. There, I checked the lines in the .bashrc, and I had forgotten a space between the initial grep and $EMU. Although, when rebooting, the screen yet again glitches, and it won’t respond to my keypresses anymore. Huh.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.