Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • matthew
    Participant
    Post count: 18

    after much trial and error i slouch here triumphant yet stumped.

    i have my analog controllers wired directly to the gpio. Emulation Station sees them but i guess only as SNES controllers. When it trys to map the keys it asks for more inputs than i have buttons. i had to disable SNESDev from the setup menu and configure with gamecon_gpio but that defaults to SNES. i used modprobe gamecon_gpio_rpi map=0,0,2,2 to attempt to override but no luck. i have no es_input.config to speak of. any ideas?

    jplaj
    Participant
    Post count: 78

    Asking for more inputs than you have buttons is normal. You can disable them later (go to: /home/pi/RetroPie/configs/all/retroarch.cfg and under “Joypad Buttons,” make sure there’s a # before all the buttons you don’t have, and remove it from all the buttons you need to use.

    Are you having any trouble with using the controller while running your emulators?

    matthew
    Participant
    Post count: 18

    I made my own config file for ES. i just deleted it and followed your advice i had to make sure i had the right fields hashed out. i am rebooting now

    matthew
    Participant
    Post count: 18

    nope it wants to map my keys again and i get to “page up” and i can’t go any further because all the keys are already mapped. but at least i now have the values for the controller mapped out. i just can’t figure out why it thinks its an SNES controller

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.