Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • opjose
    Participant
    Post count: 2

    I have a Cubieboard4 A80 running Linaro (Debian based) Linux.

    I set the __platform to rpi2 and I am able to get the compilation going.
    However the script exits and complains about missing the libraspberry-dev libraries.

    Any suggestions on getting compilation to finish?

    I had no problems compiling EmulationStation by itself. Retropie should have no problems with the Cubieboard4’s video hardware ( PowerVR ) when compiled as per the RPI2.

    petrockblog
    Keymaster
    Post count: 1827

    you will need to add a new target to the source. many of the retropie “modules” (emulators etc) for rpi2 platform will build specifically for the rpi gpu.

    assuming ES works from Xorg on the cubieboard, you could look at the implementation of the x86 platform and work from that (you basically need a platform config that builds for arm – uses the default sdl1/sdl2 assuming that works, but doesn’t try to use mali or the broadcom gpu). the x86 dependencies are probably correct for you in this case.

    this requires code changes to the retropie script.

    opjose
    Participant
    Post count: 2

    Thanks I’ll give that a try.

    The SDL1 & SDL2 libraries work on the Cubieboard4 and it uses the PowerVR.

    I’ve had success getting graphic programs written for the RPI2 to run on it when compiled from sources.

    The first time I tried adding RPI2 sources, when I performed an apt-get for the rpi2 required libraries it tried to download and install the whole O.S.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.