Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • Quantico
    Guest
    Post count: 908

    Hi, everyone.

    Any chance of Coleco be released in an update of the RetroPie?

    It is possible to compile the ColEm with some changes to RetroPie, with the permission of the author.

    by author:

    “If you would like to port ColEm to another system or make changes in ColEm’s code, please, contact me by email or some other means. Be aware that ColEm source code is freely distributable, but it is not public domain and it is not released under GPL. You can not use it for commercial purposes, distribute, or change it on your own, unless you contact me to arrange the conditions of such use and get my permission. Feel free to look at it though. “

    Quantico
    Guest
    Post count: 908

    I did it, ColecoVision is working on my RetroPi

    But i can play on keyboard only.

    If someone want to try, just compile ColEm and edit <command> TAG on es_systems.cfg:

    <command>xinit /opt/retropie/emulators/colem/colem -scale 1 %ROM%</command>

    Add coleco bios on colem dir and roms on /home/pi/RetroPie/roms/colecovision

    petrockblog
    Keymaster
    Post count: 1827

    Sounds good!

    Could you post a short installation guide, e.g., in form of a bash script here?

    Quantico
    Guest
    Post count: 908

    I’m not very familiar with bash script yet, maybe in the future i can help in this regard.

    First, get the linux portable source code in http://fms.komkon.org/ColEm/

    The current package is ColEm29-Source.zip

    Unpack the zip file (type unzip ColEm29-Source.zip)

    Now, go to the ColEm/Unix and type make.

    After compile and before to run colem, is necessary put the bios COLECO.ROM in then same folder. I found the “ColecoVision BIOS (1982).rom” on web and rename to COLECO.ROM.

    Create the folder “/opt/retropie/emulators/colem” and put the colem binary and COLECO.ROM there

    Now, create “/RetroPie/roms/colecovision” and edit es_systems.conf:
    <system>
    <fullname>ColecoVision</fullname>
    <name>colecovision</name>
    <path>~/RetroPie/roms/colecovision</path>
    <extension>.rom .ROM .col .COL</extension>
    <command>xinit /opt/retropie/emulators/colem/colem -sync 130 -skip 0 %ROM% </command>
    <platform>colecovision</platform>
    <theme>colecovision</theme>
    </system>

    If emulation get too fast or slow, set the sync option.

    —–

    Note: On my config.txt, framebuffer_width is setting to 320 and framebuffer_height to 240. To adjust screen to get better on my TV, i edited ColEm/Unix/Unix.c:

    #define WIDTH 410 //272 /* Buffer width */
    #define HEIGHT 300 //200 /* Buffer height */

    int UseZoom = 1; /* Zoom factor (1=no zoom) */

    SetVideo(&ScrBuf,80,50,WIDTH,HEIGHT);

    Quantico
    Guest
    Post count: 908

    Now i’m adding support for usb joystick, with SDL joystick lib.

    Still not 100%, but soon will be ok.

    Dirkshirt
    Guest
    Post count: 908

    Thanks Quantico. I got it to work following your instructions. However I did have to make one change to the command line in es_system_cfg. After I did the “make” step” it put the colem file in a folder called Unix. This may be because of the emulator I download. Although I used you link.

    This is what mine looks like.

    <command>xinit /opt/retropie/emulators/colem/Unix/colem -sync 130-skip 0 %ROM%,<comand>

    I also had to put the BIOS file in the Unix folder as well. Also check your case sensitive as the folder is made as ColEm. Either make your command line that or just rename the folder colem.

    Once you get the joystick up and working let us know. Thanks again.

    Mark
    Guest
    Post count: 908

    Let me know if I can give any help/testing with getting a joystick working with colem. I’d love to be able to rock Gorf again from my couch.

    Thanks for the hint about editing the width and height in the source, I’ll try that sometime.

    osias
    Participant
    Post count: 28

    Any word on getting this included in the default program, I would like to play my coleco roms as well.

    David
    Participant
    Post count: 22

    I am getting the following error when compiling ColEm version 3.2 on my Raspberry with Retropie.

    Unix.c: In function ‘RefreshScreen’:
    Unix.c:194:12: error: expected expression before ‘Screen’
    Unix.c:194:12: error: too few arguments to function ‘RPLShow’
    In file included from Unix.c:17:0:
    ../../EMULib/Record.h:58:6: note: declared here
    make: *** [Unix.o] Error 1

    Could someone please share version 2.9 with me?

    sniffus
    Participant
    Post count: 1

    Check M.E.S.S., it includes a colecovision emulator and it will work with game pad and other controllers.

    I am waiting on my Ultimate InTV controller usb dongle thingy. Ordered it last night ’round 2am, groggy and sleepless night. Perfect timing for frivolous spending I have been contemplating to do for months… ;-)

    Ps. I’m sure you can get ColEm going, might be much more work and don’t know how well the joystick support will work.

    M.

    meneerjansen
    Participant
    Post count: 97

    Tried to compile ColEm w/ help of instructions in post #27092 above. Only source code version currently downloadable is ver. 3.3. I believe I have RetroPie ver. 3 (dunno how to check that, installed RetroPie last week). The make command exits w/ an error message. So it’s not possible to use ColEm for the Colecovision.

    Some people advise to use Mess, advMess or even FBA incarnations for the Colecovision. I can not find instructions on how to install/compile those on RetroPie anywhere unfortunately.

    Any progress on the Colecovision front?

    P.S. Found the source code for ver. 2.9 of ColEm via the Wayback Machine (http://web.archive.org/web/20140806040849/http://fms.komkon.org/ColEm/) (zip file included in this post for others to try and compile). Tried to compile that one. This one indeed compiles successfully!

    [attachment file=”ColEm29-Source.zip”]

    David
    Participant
    Post count: 22

    Try out the CoolCV emulator at:

    http://atariage.com/forums/topic/240800-coolcv-emulator-for-mac-os-x-linux-windows-and-raspberry/?hl=%20coolcv

    There is a 6.2.pre version in the thread that works in full screen.

    meneerjansen
    Participant
    Post count: 97

    Got it working now w/ the proper coleco.rom BIOS. But I have no sound… Weird.

    meneerjansen
    Participant
    Post count: 97

    Downloaded said coolcv_pi executable but still no sound…? Did you try it? And did you have sound?

    meneerjansen
    Participant
    Post count: 97

    Wait a minute. If I start Mame from the commandline there’s no sound either… How does one start a game WITH sound in RetroPie from the commandline? Strange… :?

    David
    Participant
    Post count: 22

    I have installed CoolCV on a Raspberry 2 using Retropie 2.6. The emulator works fine with sound and joysticks. Are you using version 0.6.1 or 0.6.2 of the emulator? I tried both of these. 0.6.2 gives you full screen.

    I ran the emulator from a command line and not Emulation Station.

    meneerjansen
    Participant
    Post count: 97

    Strangely enough I cannot get sound from any emulator from the command line. Only via Emulationstation…

    BTW I’m running RetroPie 3 (I think, I installed it last week) on a Pi 1B and I downloaded coolcv from the last comment in the mentioned AtariAge forum from the date of the 10th of November 2015 (strangely indicated as 11-10-’15 instead of 10-11-’15: American English?).

    David
    Participant
    Post count: 22

    Did you configure CoolCV to run from Emulation Station? If so, did you get sound from it? If you have not tried it from ES, would you?

    I do not know why you would not get sound from the command line. I have not tried Retropie 3.x yet.

    meneerjansen
    Participant
    Post count: 97

    [quote=109759]
    Did you configure CoolCV to run from Emulation Station? If so, did you get sound from it? If you have not tried it from ES, would you?
    .
    I do not know why you would not get sound from the command line. I have not tried Retropie 3.x yet.
    [/quote]

    No sound when I try to run coolcv_pi from within Emulation station. This is probably because ES is simply a frontend. However, ES runs emulators via a script that probably activates audio the proper way. Because when I run mame4all from within ES it does have sound (of course) but from the commandline it doesn’t. Think I’ll start a new topic on sound.

    [edit] Sound issues from command line solved. See this topic. however, only ColEm still has no sound… Which is a pity because coolcv_pi runs too slow but ColEm can be tweaked to run faster.

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.