Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #100057

    hi i am on 3.0.2 beta and can i play Colecovision roms ? and if so i cant see the Colecovision folder to put the roms in . thanks


    Retropie doesn’t yet have colecovision.


    does the msx emulator (fmsx-libretro) not support .col files?

    drop a colecovision rom in the msx folder and give it a go, i would but I’m not able to at the mo


    Why is colecovision listed in the RetroPie-Setup wiki then? :)


    “Below is a list of all available platforms in the database and their IDs.

    “[31] Colecovision”


    That list refers to the database ID’s for thegamedb.net API (mainly used for scraping rom data) I’ve ammended the wiki to more accurately reflect what that list is for. The database supports those systems, but retropie may not have all of them installed let alone be able to to run them (like the Wii or Wii U). Colecovision has not yet been added to RetroPie. (plus that list is 3 years old)

    The side bar on the wiki is an accurate reflection of what retropie has as part of its setup script. Colecovision is not yet part of it, though I have heard of some people compiling mess and getting Colecovision to work with that, but I haven’t tried it myself.


    I’ve been trying all day today to compile various colecovision emulators and get trapped in compilation error hell and can’t find my way out. :(

    adamem works except I can’t get past the SVGA section and when i do play it it’s the size of a (large) postage stamp on the screen. Games are playable though except it requires X and doesn’t run in the command line

    <builtin>: recipe for target ADAMEm.o failed
    make[2]: *** [ADAMEm.o] Error 1
    make[2]: Leaving directory /home/pi/src/adamem
    Makefile:12: recipe for target svga failed
    make[1]: *** [svga] Error 2
    make[1]: Leaving directory /home/pi/src/adamem
    Makefile:24: recipe for target linux failed
    make: *** [linux] Error 2

    ColEm. Eventually errors out as well…

    ../../EMULib/Record.o: In function RPLRecord:
    Record.c:(.text+0x0): multiple definition of RPLRecord
    ../../EMULib/Record.o:Record.c:(.text+0x0): first defined here
    ../../EMULib/Record.o: In function RPLPlay:
    Record.c:(.text+0x2c4): multiple definition of RPLPlay
    ../../EMULib/Record.o:Record.c:(.text+0x2c4): first defined here
    ../../EMULib/Record.o: In function RPLTrash:
    Record.c:(.text+0x5a4): multiple definition of RPLTrash
    ../../EMULib/Record.o:Record.c:(.text+0x5a4): first defined here
    ../../EMULib/Record.o: In function RPLInit:
    Record.c:(.text+0x5c4): multiple definition of RPLInit
    ../../EMULib/Record.o:Record.c:(.text+0x5c4): first defined here
    ../../EMULib/Record.o: In function SaveRPL:
    Record.c:(.text+0x5f0): multiple definition of SaveRPL
    ../../EMULib/Record.o:Record.c:(.text+0x5f0): first defined here
    ../../EMULib/Record.o: In function LoadRPL:
    Record.c:(.text+0x83c): multiple definition of LoadRPL
    ../../EMULib/Record.o:Record.c:(.text+0x83c): first defined here
    ../../EMULib/Record.o: In function RPLShow:
    Record.c:(.text+0x9ec): multiple definition of RPLShow
    ../../EMULib/Record.o:Record.c:(.text+0x9ec): first defined here
    collect2: error: ld returned 1 exit status
    Makefile:13: recipe for target colem failed
    make: *** [colem] Error 1

    libretro-fba-master compiles forever then crashes at this point:

    src/burn/drv/pst90s/d_1945kiii.cpp: In function INT32 DrvFrame():
    src/burn/drv/pst90s/d_1945kiii.cpp:420:1: internal compiler error: in push_minipool_fix, at config/arm/arm.c:13055
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-4.7/README.Bugs> for instructions.
    Preprocessed source stored into /tmp/cciq84Bz.out file, please attach this to your bugreport.
    makefile.libretro:571: recipe for target src/burn/drv/pst90s/d_1945kiii.o failed
    make: *** [src/burn/drv/pst90s/d_1945kiii.o] Error 1

    I haven’t tried msx yet.


    Trying our coleco roms with msx (the one that comes with retropie) and no go. Perhaps there’s a change to the commandline in es_systems that needs to be made? I tried using .col and .rom extensions and I just get the blue msx screen and nothing works, not even the keyboard. (except for F1, F2, F3, and F4)


    lr-Bluemsx runs colecovision (install it from the setup script)- it pulls from my fork of bluemsx, you just have to change the core option to Colecovision, then you add the coleco.rom bios to the colecovision folder in the machines folder (in the bios directory)

    … But the only caveat is it hasn’t been coded to accept keyboard or joypad input yet… So it’s currently useless- but I have tested it and the games do run.


    I see. We’re getting close! Anyone have any luck compiling the other emulators I mentioned?


    I haven’t tried, colem looked promising to me but the developer is restrictive about his code so it would never be incorporated into the retropie project. Wish I knew more about coding so I could integrate the bluemsx controls. Colecovision I think is the last major system retropie needs.


    I have a working build of adamem/cvem that I’m trying to get to play nice with retropie. The games start but when I hit F-10 to quit it locks the whole system up and I have to reboot.

    This is my entry in es_systems.

        <extension>.rom .ROM .col .COL</extension>
        <command>/home/pi/src/adamem/adamem/cvem  %ROM%</command>

    Do I need to use the runcommand.sh script? I wasn’t sure how to add an entry to that.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.