Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 2

    I have everything set up and running well, but the Megadrive controls are not mapped correctly. I read a bunch of posts saying to edit megadrive/retroarch.cfg, but I cannot for the life of me figure out how. When I go into using “sudo nano retroarch.cfg” I cannot find the buttons, only keyboard inputs.

    I am extremely new to linux as well as raspberry pi, But I have gotten this far and all I want if for this one last step to be finished.

    Also, I am using RetroPie 2.3 in case that makes a difference.

    Anonymous
    Inactive
    Post count: 2

    Also,
    when I map the buttons for megadrive should I do

    input_a_btn = “9”
    input_b_btn = “10”
    input_c_btn = “11”
    input_x_btn = “6”
    input_y_btn = “7”
    input_z_btn = “8”

    because the buttons are A, B, C, X, Y, Z in megadrive?

    or does it need to stay in the SNES format like it is automatically?

    krux02
    Participant
    Post count: 8

    yes this is what I would like to know, too. I am not new to emulators, not to linux, but the emulation station 2 does a pretty good job of hiding, how it works.

    As far as I found out, the retroarch.cfg does not have any input_c_btn or input_z_btn. But there is a dgenrc, which lists all the buttons that are important for a megadrive controller. I think (but I could be wrong) that the button numbers you define there, are new indices of a virtual controller.

    bobbyt
    Participant
    Post count: 71

    By default it maps only to A B & Z, as the default Genesis/Megadrive controller had only 3 buttons.

    The 6 button controller was released at a later date (I had a Genesis as a kid and I remember upgrading all my controllers around the time Mortal Kombat came out for the home systems).

    If you go into the RetroArch config menu (by hitting F1 on your keyboard by default), you can toggle the emulator from 3 button to 6 button mode under one of the menu options…

    Once you do this the custom mapping will need to tied to the following buttons:

    input_player1_a_btn = “#”
    input_player1_b_btn = “#”
    input_player1_y_btn = “#”
    input_player1_x_btn = “#”
    input_player1_r_btn = “#”
    input_player1_l_btn = “#”

    Note that there isn’t a 1 to 1 mapping of A B C X Y Z on these, but if you play around with them for a while eventually you should be able to figure out which button corresponds to what in 6 button mode…

    krux02
    Participant
    Post count: 8

    thank you very much. Is there a way to configure it that the mapping is only done on one gamepad, but different on another gamepad. I only have one 6 button gamepad. Or do I need to redo all button mapping when gamepads are plugged in a different order?

    Anonymous
    Inactive
    Post count: 17

    I just posted a the same question in another post, I suspect you would have to have to use one config for one controller. Then plug in the other controller and make a mapping in the main file, it would have to distinguish itself from the other one by using input_device = #######
    Until someone else chimes in the best bet is to use one controller for everything, or modify one controller to use specific buttons in that particular emulator.

    shwisha
    Participant
    Post count: 11

    I enabled 6 buttons from the settings menu and then recorded what the current inputs where for all the kick and punch buttons. I went to /opt/retropie/configs/megadrive/retroarch.cfg and remapped the buttons accordinly… but for some reason when I go back into the game the buttons are definitley remapped but still incorrect. I tripple and double checked what I was doing and can’t figure out where I’m going wrong =\

    I was susuccessful with this approach to mapping the SNES controller but can’t figure out what’s going on here.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.