Homepage Forums RetroPie Project Everything else related to the RetroPie Project Change default emulator problem?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #121238

    Recently I switch to latest RetroPie, installed lr mess emulator and add some system in emulators.cfg

    When I try to change default system in emulationstation by pressing m or x, I briefly noticed at the bottom of screen a message “Couldn’t open temporary file /opt/retropie/configs/advmess/***** permission denied
    I dont have this problem with other emulators.
    Its interesting that I only cant change global default emulator, but it allow me to change default emulator for specific rom.
    What should I do to get rid of this permission issue?

    Another annoying problem is those new splash screen with blue background and info message “Press x or m to configure launch options for emulator… Errors will be logged to /tmp/runcommand.log” on the middle of screen.
    How to change this blue backround to black and most important is there a way to shorten the delay time at the start of each game?
    While I used retropie 3.0 emulator and each game start much faster, and now this info splash screen stand a several seconds and delaying the startup time.


    Have you tried

    sudo chmod -R 777 /opt/retropie/configs/advmess/

    I would not think permissions to be an issue in a local setup


    777 is rwx for all users – which is not correct for files that are not executable and it also gives write access to all users. You probably just want to chown to the pi user – but getting some information is better first eg the output of

    ls -lRa /opt/retropie/configs

    (via pastebin or similar – not posted directly to the forum)

    If you have a blue background on the launch menu something else is wrong as you are missing a config or it can’t be read. You might do better to start with a fresh image – sounds like you have messed it up. I can advise better with the config listing.


    Yes you right, I tried fresh image and background in launch menu is black.
    But this is more cosmetic problem, much bigger issue is delay before any emulator starts for about 3 seconds.
    Can I shorten this delay and maybe add some command in /opt/retropie/supplementary/runcommand.sh to change this blue background color in black.
    I have lots of customized settings and I dont want to start over with fresh image if possible.
    Recently I sucessfully make upgrade from whezzy to jessie and update retropie from 3.0 to 3.6, without any other issues, except those I mentioned in my initial post.
    If its possible to correct this, it would be almost perfect migration, because everything else works just fine.
    Also can you specify what config listing you like to see?
    I think that this problem is related with runcommand.sh, but I dont know how to change background colour in emulator launch menu and shorten appearance of this launch screen.


    It delays for 2 seconds vs 1 second delay on earlier versions. You can disable the launch dialog completely to remove this delay. https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand


    Ok, first problem with premission issue is solved when I change ownership to pi, thanks buzz!

    Problem with retroarch launch menu still exist, cant cahnge those blue background color and cant remove launch dialog, becouse i dont have listed option for configuring Runcommand launch menu.
    Maybe I still have older version, becouse or I dont know how to get this option:

    Do I need to update this menu and how?


    I would start from a new image to be safe due to the problems with your current setup.


    Missing configs/all/runcommand-launch-dialog.cfg causing blue background in launch menu.
    After reinstalling with sudo ./retropie_packages.sh runcommand install problem is solved.
    Found solution here: https://m.reddit.com/r/RetroPie/comments/45ouzi/how_do_i_get_rid_of_the_ugly_blue_loading_screen/


    Yep – but I think with your permission problems you will benefit from a fresh install. Also if you are on Debian Wheezy, support for that is being discontinued (depending when you installed originally)

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.