Homepage Forums RetroPie Project Everything else related to the RetroPie Project Can´t save settings on Snes9x Next and Psx

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #100683

    Hi, Im running Retropie 3.0 Beta 4 and everything works fine for me except:

    In the Snes9x Next 1.52.4 emu isn’t possible to save the config option Superfx Overclock, everytime I exit that option doesn’t save.

    Same thing happens in the PSx emu (PCSX-ReARMed r22) the core option enhanced resolution doest seems to save everytime I exit.

    Do you know the command line for those options to add them to the retroarch config and make them permanent?

    Many thanks!


    I am having the same issue with PCSX-ReARMed on Beta 4 – the stand alone PSX emulator, where I am unable to make my configuration permanent.

    After configuring the controllers, I can use them within the current game, but after quitting and returning, they need to be configured again.

    Can anyone shed any light on this issue for people experiencing this issue?

    PCSX-ReARMed seems to run faster than the libretro version on Pi B+ – otherwise I would use it instead.


    Did anyone find a way to save a config for stand alone PCSX-ReARMed or find a fix for the first post in this thread?


    I also have exactly the same problem with PCSX-Rearmed and RetroPie v3.0 RC1.
    Every time when the emulator starts, I have to reconfigure joypad again.
    If there is a way, at least to make the joypad works?
    It’s really a shame, because the emulator works very nicely and smoothly on RPI2, but this annoying problem drastically prevents comfortable use.
    Does anyone have a closer experience with this emulator or knows what could be the cause, why he failed to save global config.
    I wonder what he looks like the original global pcsx.cfg file for this emulator.
    Maybe he cant find the right location for saving and reporting the error because of it.


    Are you talking about changing and saving settings with RGUI?

    If so, make a save with and without the change, that will produce two new files in /opt/retropie/configs/{systemname}/

    Use a diff file checker to see the difference, and put the resulting few lines (probably 2 or 3) into /opt/retropie/configs/{systemname}/retroarch.cfg

    Or you could just bodge it by renaming the newly created file above to be retroarch.cfg, but I wouldnt recommend that.


    Floob, why wouldn’t you recommend replacing the “sys name*/retroarch.cfg” file with the one created/saved from the GUI?
    Also – would a, example given, “sudo cat libretroconfig.cfg >> retroarch.cfg” work fine?

    Thanks in advance.



    I wouldnt recommend it because
    – The formatting gets changed making it a nightmare to make manual updates to afterwards
    – The file will then contain all of the retroarch.cfg settings making it contain far more info than you need, which makes it difficult to see what is really just needed for that emulator as opposed to all emulators.
    – Any custom changes that you may have made to your pre-existing retroarch.cfg wont be held within there anymore
    – There would no longer be an -include- existing in the file to reference the /all/retroarch.cfg which means that when you run a game, no changes in there would be looked at
    – This could also risk losing the reference that /all/retroarch.cfg makes to the auto controller directory
    – If it does keep looking at the auto controller directory, it has a conflict with the controller settings that are then showing in the newly created config file, making debugging controller issues very difficult.
    – Any RetroPie based settings such as pre-setting the hotkeys to work in a certain way could get ignored as they would be in the /all/retroarch.cfg, although that may get carries accross.
    – There are basically a lot of settings that would get ignored and/or duplicated

    That said, it will most likely work, I would just despair at trying to debug any retroarch issues someone may have with that approach. Unless of course RetroPie wasnt being used and it was a standalone installation.

    And no, I wouldnt add the file to the end of the existing file, as that would really complicate things as it would continue to pull in the main all/retroarch.cfg and then repeat the whole config file that had been generated, lots of conflicts then.


    [quote=102726]Are you talking about changing and saving settings with RGUI?[/quote]

    I just want to save my settings in PCSX-Rearmed emulator (installed from experimental packages), because every time I try to do it with a “save global config” option, it gives me the error “failed to save config”
    I want to emulator save and remember all the settings that I did (especially joypad configuration), but he allways fails.
    I really dont understand what the problem is, this is a fairly well-known emulator for popular platforms like Playstation, but still havent found the solution.


    Oh, I use the default libretro-pcsx-rearmed version which uses RetroArch. I’m afraid I havent tried the one in experimental.

    If it helps, my setup is here:


    Thanks Floob for explaining my questions about retroarch.cfg

    Regards/ Alucard


    [quote=102760]Oh, I use the default libretro-pcsx-rearmed version which uses RetroArch. I’m afraid I havent tried the one in experimental.

    If it helps, my setup is here:
    <span class=”embed-youtube” style=”text-align:center; display: block;”>



    Thanks for this video its very helpful, especially psx section.
    About this stand alone pcsx rearmed I still no luck with saving emulator configuration.
    Can I ask you to take a look at whats going on here?
    You obviously have a lot more experience with retropie than me, so maybe you can figured out, where problem is?
    I looked at the text output, after the emulator exit, and I see this:
    failed menu_load_config: ./.pcsx//opt/retropie/configs/psx/pcsx.cfg
    For some reason, pcsx rearmed cant save this global pcsx.cfg config file.
    Since I cant produce this file, I am stuck here and frankly I’m out of ideas how to resolve this problem.
    Currently emulator works with keyboard and only can see D-pad buttons on joypad, so i must remap joypad buttons every time at start, becouse he cant save and read config.
    If there is a way to support retroarch joypad configuration, it would be enough solution for me.


    Do you even have write/read permissions in your /opt/retropie/configs/ folder?

    cd /opt/retropie/
    ls -l

    You “configs” folder should have the permissions “drwxr-xr-x” (755) as user “pi”.

    How does it look when you check this out?

    Good luck/ Alucard


    Yes, I check this and config (same as psx) folder has drwxr-xr-x permission and user pi.
    I also checked all folders and subfolders created by emulator itself and all of them have drwxr-x— premission.

    Interestingly, even the emulator refuses to save global pcsx.cfg file, he can save individual game cfg file.
    Unfortunately, for some reason emulator cant retreive this saved game config, when starts and it brings us back to the beginning…


    In meantime, I was looking for detailed information on the internet, but looks like no one has solved this problem, yet.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.