Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • isarai
    Post count: 5

    OK so i’m new to the Raspberry Pi in general, just shipped today and got it hooked up booted up retropie and everything seemed great. could even navigate the menu with my 360 gamepad right out the box. Then i realized i can’t control anything other than the menu, doesn’t work with ANY game and i’ve tried SO MANY things and nothings seems to be working after following these videos

    I’ve only managed to get so much as the “1” light showing on the controller, and “A” and “B” to work but the d-pad doesnt register. also would like to mention that following the first vid the “register for retroarch” thingy doesn’t read any imput, i press buttons when it tells me to and nothing happens till it says “timed out” for each button. and with the second vid, once i put the long line of code in i get some error like

    [ERROR] XboxdrvDaemon::run(): fatal exception:
    Error: No stuitable uinput device found, tried:
    /dev/input/uinput: No such file or directory
    /dev/uinput: permission denied
    /dev/misc/uinpit: no such file or directory

    When i start a rom i get big yellow letter saying it recognizes my 360 gamepad but only A & B work, can someone help me man!

    Post count: 1

    I’m also having the exact same problem and i’m almost ready to give up after about 5 days of retrying and re-installing.

    I installed 2.3, go to RetroPie-Setup – run the .cfg

    Install Xbox 360 controller drivers, then i get a single light on the controller. Go into EmulationStation – configure controller. It works perfectly.

    Go into a game, only A and B + start work, rest doesn’t.

    Please please please, help US get this working! It’s so frustrating!


    Post count: 5

    OK, so i gave up on the 360 gamepad, figured the one that works easiest on PC would work on the pi but that didn’t work out, after going through a few more USB controllers i had laying around i found that the best and easiest one is the Dualshock 4 (PS4 controller) my guess is that the RetroPie/RetroArch has an issue managing analog inputs since my PS3 controller didn’t work and only the face buttons worked for the 360, and also that the PS4 switched to a purely digital input system from the PS3’s analog.

    All i had to do was boot it up while wired via USB, go through the RetroArch gamepad registration, and now everything works great (though be sure to just barely tap the triggers when registering with RetroArch, otherwise it’ll go a bit wonky and register it for more than one button really fast)

    So i’d say use your PS4 controller if you have one, otherwise fond a simple gamepad that has little to no analog systems in it (a standard PC gamepad should do fine) to keep from going through all the hassle.

    Still hope this issue gets solved though for the many others having the same issue

    Post count: 908

    i had the same issues like you guys did, i finally got it working for my xbox…whats the commands you are using to set up the xbox controllers?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.