Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • Anonymous
    Post count: 25


    Raspberry Pi 3 Mod B + RetroPie v3.6

    Before, like in the 3.0 alpha/RC-versions it worked.

    But now when, in-game, I bring up the RGUI/RetroArch GUI and configure my controller for every specific emulator, and small tweaks and what not… I can’t save the new config.

    I get a short brief yellow message saying something like this:
    Failed to save config to */xxx/xxx/xxx/place of emulator, I guess*“….

    … and then the emulator exits back to Emulationstation.

    It’s really enerving to have to manually set input_a_btn = “1” via the Terminal for each button in each retroarch.cfg in for instance /opt/retropie/configs/psx/retroarch.cfg.

    How come I can’t write/save this new config I’ve done via RGUI?
    I’ve tried different (read/write/execute) permissions etc.. but no such luck.

    Does anyone recognize this fenomena?

    Thanks in advance/ Alucard =)

    Post count: 1629

    This may help

    or if you want to remap buttons

    Post count: 25

    Thanks Floob.

    Watched it all but I got no wiser.

    I did however notice that when I try to save, for instance my RGUI configs for RGUI, the yellow message says something like:

    Failed to save configuration file to “/opt/retropie/configs/psx/.cfg”

    What startles me is the “.cfg”… in the end of the string?

    In the 3.0 versions when I was successfull saving my configs it always said (like):
    “Sucessfully saved configuration file to “/opt/retropie/configs/psx/retroarch.cfg”

    … with the “retroarch.cfg” fully written there.

    I’ve checked the “emulators.cfg”-file and there’s a path to /xxx/xxx/psx/retroarch.cfg

    RetroArch also responds/remembers to that specific/custom tweaked “retroarch.cfg” file after I’ve manually assigned the keys via the Terminal/Putty with nano.

    That’s what bothers me… “.cfg”… instead of “retroarch.cfg”, when everything else seems reasonable and in right order.

    Do you know why it tries to save a no-name/”blank” “.cfg”-file when I try to save the new settings via RGUI – instead of “retroarch.cfg”?

    Many thanks in advance Floob… RGUI is the shit… the terminal can be.. well, tiresome after a while =)

    Regards/ Alucard

    Post count: 1629

    Fire up a game, and bring up RGUI with Select + X – then remap the buttons. Where does it save it to?

    Post count: 25

    Hi again and thanks for quick answers Floob.

    Usually I used to bring up the RGUI and choose “Settings->Input->User 1 Binds”.. and remap there, which created a for example, a “fceumm.cfg” config file in the:
    “/opt/retropie/configs/nes/” directory where the retroarch.cfg is allocated.

    But I watched closer on your second video now and went with the RGUI in SNES.
    “Quick Menu->Core Input Remapping Options->Save Core Remap File”.

    Successfully saved in:
    “/opt/retropie/configs/snes/Snes9X Next/” as a “Snes9x Next.rmp”-file.

    Hmmm? =)

    looks like this:

    input_libretro_device_p1 = "1"
    input_player1_analog_dpad_mode = "0"
    input_libretro_device_p2 = "1"
    input_player2_analog_dpad_mode = "0"
    input_libretro_device_p3 = "1"
    input_player3_analog_dpad_mode = "0"
    input_libretro_device_p4 = "1"
    input_player4_analog_dpad_mode = "0"
    input_libretro_device_p5 = "1"
    input_player5_analog_dpad_mode = "0"
    input_libretro_device_p6 = "1"
    input_player6_analog_dpad_mode = "0"
    input_libretro_device_p7 = "1"
    input_player7_analog_dpad_mode = "0"
    input_libretro_device_p8 = "1"
    input_player8_analog_dpad_mode = "0"
    input_libretro_device_p9 = "1"
    input_player9_analog_dpad_mode = "0"
    input_libretro_device_p10 = "1"
    input_player10_analog_dpad_mode = "0"
    input_libretro_device_p11 = "1"
    input_player11_analog_dpad_mode = "0"
    input_libretro_device_p12 = "1"
    input_player12_analog_dpad_mode = "0"
    input_libretro_device_p13 = "1"
    input_player13_analog_dpad_mode = "0"
    input_libretro_device_p14 = "1"
    input_player14_analog_dpad_mode = "0"
    input_libretro_device_p15 = "1"
    input_player15_analog_dpad_mode = "0"
    input_libretro_device_p16 = "1"
    input_player16_analog_dpad_mode = "0"

    I’m used to input_b_btn = “0” and such format in the respective emulators own retroarch.cfg

    Where is this taking me to you mean?
    Have I missed something, I can’t make anything.. really, from the “.rmp”-file

    Thanks for your patience.



    PS: The “User 1 Bind Keys” always tries to save, but fails, into for example:
    “/opt/retropie/configs/psx/”-folder where the retroarch.cfg file is.

    Have never tried anything else than via RGUI or nano/terminal to type in the correct values into each emulators respective retroarch.cfg – or do a “cat fceumm.cfg >> retroarch.cfg” – worked well until this release.

    New things are, well too new, for me.. I guess =)

    Post count: 25

    I managed to extract the data from the “.rmp”-files and pasted it into each emulators respective retroarch.cfg file. =)

    Thanks for the help Floob!

    Case SOLVED!

    Post count: 9

    So I have followed this and I can only get my player one controller to save when I configure player two the settings never save. I am using wireless Xbox 360 controllers

    Post count: 1827

    there was a bug in retroarch – I have updated the binaries today, so you could reinstall from retropie-setup menu 5 to get a newer version to see if it is fixed.

    Post count: 9

    You nailed it thank you. Now if you could come up with a fix for the dream cast that would be great. I followed that video also and only the analog stick on player 2 would work. Thank again.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.