Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • robertybob
    Post count: 219

    Hi. For some reason I can no longer SSH into my RetroPie installation (2.3) , nor the new 2.6 image I’ve installed on a separate card.

    I have tried Googling this, but tbh the results have been rubbish. Does anyone know why this would suddenly have stopped working and what I can do about it?

    I know my Wifi dongle is working as I download updates on the Pi using it, and I’m definitely entering the correct IP address into Putty / WinSCP.

    Any help would be much appreciated :)

    Post count: 219

    Also, I have not assigned a static IP.. and the reason why Googling is pointless is that the things that worked for other people can’t work for me


    editing /etc/xinetd.d/ssh < doesn’t exist in RetroPie (?)

    Post count: 8

    what client are you using to connect, are you getting any error message?

    Post count: 10

    ….mmh sounds weired, I would suggest to start with some basic diagnostics.
    please log on your retropie and paste here the output of those two commands:
    sudo ifconfig

    on your notebook / desktop pc please download and start Angry-IP-scanner
    (a nice little tool im using to discover my intranet ;) )
    or just try to ping the IP of you retro pie and tell us the result

    Post count: 1629

    Have you tried connecting to hostname RETROPIE as opposed to an IP?

    Post count: 219

    Hiya, thanks for the replies.

    I’ve tried using Putty and WinSCP to connect but they come back with Timeout errors.

    I don’t know how to connect using just a hostname with those two programs , could you tell me how?

    I can ping Google and my Pi is picked up using Nmap (a network scanner tool) but attempting to ping the Pi results in a timeout error message too. I’m beginning to think, as it works perfectly fine via LAN, that it’s a router issue :(

    Post count: 10

    how do you connect with puty ?

    your config should look like:

    Host Name
    [pi@192.168.0.XXX (<- The pis IP-Adress shown in Nmap)]


    Connection Type
    [ ]raw [ ]telnet [X]SSH

    when you leafe the rest on default options, that should it be…

    please could you descripe more detailed what you mean with

    … as it works perfectly fine via LAN, that it’s a router issue

    Post count: 170

    My assumptions from reading the previous posts. If they are wrong let me know.

    • SSH works when you have a wired connection
    • SSH doesn’t work over a wireless connection
    • The wireless device can access the internet
    • You can’t ping the pi over a wireless connection

    Is the computer attempting to connect to the pi wired or wireless?

    Things to Check:
    You can try checking your routers settings. Some routers are able to isolate each wifi client from each other and the lan. Look for something mentioning isolation.

    Post count: 2

    Hi All About Code Here,

    1. Press menu (you selected this during setup)

    2. Select exit from the list

    3. Type sudo raspi-config into console

    4. Select Advanced Options

    5. Scroll down and select A4 SSH

    6. Enable SSH

    7. Select Finish to return to command line

    Post count: 153

    I’ll bet you’re having the same problem I had at one point…double check your inet address for the pi you are using…they change!

    Post count: 219

    I’ll have a go at all of your suggestions tonight and report back :)

    Post count: 219


    Please see image below


    (I installed LXDE and can’t figure out how to stop the Pi booting to the graphical log-in screen- but I’m not worried about that at the moment lol).

    these are my PuTTy settings

    and this is the error message I receive


    The assumptions Selph made were correct, if I connect this Pi to my router via LAN, I can SSH successfully.

    I have scanned using Angry IP Scanner and it didn’t pick up my Pi :(

    Post count: 170

    Is the windows machine on wired or wireless?
    Are the wired and wireless router the same device?
    What is the ip of the windows machine?
    Is the pi connected to any kind of guest wireless network?
    Do you have issues connecting to/from other devices on the wireless network?

    Traffic doesn’t seem to be passing to/from the windows machine and the pi. My thinking is they are isolated somehow, either physically or logically.
    If your access point and wired router are different devices and you have different subnets, you’ll want to switch your wireless router to bridge mode and disable its DHCP server.
    If they are the same device your router may be have some option to disable isolation or bridge the two networks

    Post count: 1

    [quote=88371]Have you tried connecting to hostname RETROPIE as opposed to an IP?[/quote]
    RETROPIE as the host name worked for me then just used pi and raspberry for the username and password. thanks floob

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.