Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • buzzby
    Post count: 4

    Hi Everyone,

    I have just built up the GPIO adapter which i think went quite well given i haven’t soldered anything for years. Have plugged it all in expecting some sort of issues but i have a problem that i cannot get the SNESDev service to run so i cannot test or do anything with the board. I have followed the video guide and when i run the command

    service –status-all

    the SNSDev service shows [-]

    I have tried the command (remembering from memory so may not be 100% accurate)

    sudo service SNESDev start

    This does show any error but when i then check again with

    service SNESDev status

    I just see a Fail showing that the service is not running.

    I am a complete Linux noob and spend my life on windows machines so i have no idea how to even start debugging this problem.
    Just incase i somehow messed up the retropie install i redid this last night using the following
    Retore IMG to SD card (8GB)
    Sort out the free space
    Update Setup script
    Update binaries
    Enable SNESDev with option 2 (pad and buttons)

    and still have the problem.

    Any help very much needed.


    Post count: 4

    So i have had some success. I went through the setup menu and i might have pressed the wrong button or its a bug or it meant to do it. Either way i kicked of a full update and compile of everything.
    Once this had finished SNESDev is now a running service :) and the button on the GPIO adapter is working. I think you can tell where there is going.

    Neither of my snes controllers are working.

    I’m testing it with the jstest thingy but nothing is happening.

    I was confident that i had done all of the soldering correctly but i’m hoping someone can see a mistake. I’ve attached a couple of pics of my setup.

    Thanks in advance

    Post count: 4

    So i had a couple of muppet mistakes. I had the ribbon plug in the wrong way round. Switched it round and the controllers now work with the jstest thingy YAY.

    Second muppet mistake is that i have wired the ports the wrong way round so player 1 is actually player 2.

    Can this be switched by changing something in the config or do i need to rewire the ports?


    Post count: 1827

    I am glad to hear that you made the controllers work :-)

    Currently, you would have to swap the data lines on the connectors. Alternatively, you could change the configuration files, e.g., in /home/pi/RetroPie/configs/all/retroarch.cfg.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.