Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • whywilson1
    Post count: 26

    I’ve been trying for a few hours now and I have no idea how to get multiple controllers working on RetroArch or Mupen64. Using standard Xbox 360 wireless controllers with dongle.

    Here is my .cfg file

    input_device = “Xbox Gamepad (userspace driver)”
    input_driver = “udev”
    input_b_btn = “4”
    input_y_btn = “6”
    input_select_btn = “12”
    input_start_btn = “13”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “5”
    input_x_btn = “7”
    input_l_btn = “8”
    input_r_btn = “9”
    input_l2_btn = “10”
    input_r2_btn = “11”
    input_l3_btn = “15”
    input_r3_btn = “16”
    input_l_x_plus_btn = “3”
    input_l_x_minus_btn = “2”
    input_l_y_plus_btn = “1”
    input_l_y_minus_btn = “0”
    input_r_x_plus_axis = “+2”
    input_r_x_minus_axis = “-2”
    input_r_y_plus_axis = “+3”
    input_r_y_minus_axis = “-3”
    input_enable_hotkey_btn = “12”
    input_exit_emulator_btn = “13”
    input_load_state_btn = “8”
    input_save_state_btn = “9”
    input_state_slot_increase_axis = “11”
    input_state_slot_decrease_axis = “10”

    Post count: 96

    try using retroarch-joyconfig -p 1 -j 0 and retroarch-joyconfig -p2 -j1 (P for player. j for joystick number)

    Post count: 26

    [quote=93784]try using retroarch-joyconfig -p 1 -j 0 and retroarch-joyconfig -p2 -j1 (P for player. j for joystick number)[/quote]

    Could you give some more instruction on this? I found the retroarch-joyconfig file but I don’t know if I’m doing it correctly.

    Post count: 4

    I recently set this up on my pi. What I did was blacklist xpad, and install the xbox 360 driver from the retropie-setup script. Search for the blacklisting thing if you haven’t already run across that. There are several posts on it in the forums and elsewhere.

    After that I ran the retroarch-joyconfig, I think also using the retropie-setup script.

    Once that was done, I then setup the emulation station controller config. I think if you do that first, you will have problems later after installing the new xbox driver from retropie-setup.

    My first attempts at editing the .cfg files directly were a big fail, so I reloaded the img onto my sd card and started from scratch. The second attempt was much smoother.


    Post count: 26

    After trying some solutions I only managed to mess up my controller so much that I could no longer navigate the RetroPie menu itself.

    After that I reloaded a fresh img.
    BUT when I reloaded the image for whatever reason controlled 1-4 were not recognized. It was now reading controllers as 5 and 6. Somehow I solved this, but at this point I’m giving up because installing 3.0 was clean and simple except for whatever the heck happened with the controllers.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.