Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • frank-w
    Participant
    Post count: 3

    Hi,
    first i have a raspberryPi2 and retropie running, updated today with the retropie-setup-script (updated this before).

    i want to save and load snapshots in mupen64plus, but emulator does nothing on f5 and f6 and crashes on f7

    getting the log was a bit tricky, because the keyboard seems disabled (also in filenmanager [MC] started via ES).
    i can switch to console with ctrl+alt+f4, but then i can’t write anything…seems keyboard is blocked from that moment (also no ctrl+alt+del works).

    can i set save/load to my controller (Logitech rumblepad2) like in snes-emulator…googled around but found nothing but patches for recompile

    regards Frank

    frank-w
    Participant
    Post count: 3

    no idea, how to get load/save states on mupen64 working?

    i tried also changing this lines in /retropie/opt/retropie/configs/n64/mupen64plus.cfg (will not be overwritten by autoconf):

    # Joystick event string for saving the emulator state
    Joy Mapping Save State = “J0B8/B7”
    # Joystick event string for loading the emulator state
    Joy Mapping Load State = “J0B8/B6”
    # Joystick event string for advancing the save state slot
    Joy Mapping Increment Slot = “J0B8/B5”

    take the button numbers from /retropie/opt/retropie/configs/all/retroarch-joypads/LogitechLogitechRumblePad2USB.cfg
    input_select_btn = “8”
    input_l_btn = “6”
    input_l2_btn = “4”
    input_l3_btn = “10”
    input_r_btn = “7”
    input_r2_btn = “5”
    input_r3_btn = “11”

    input_enable_hotkey_btn = “8”
    input_load_state_btn = “6”
    input_save_state_btn = “7”

    load/save works in snes-emulator with the retroarch-config and the config in snes/retroarch.cfg (same buttons, but config-keynames differ):
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “10”
    input_player1_r3_btn = “11”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    is that right? i did not found any explanation of the button-numbers.

    regards Frank

    frank-w
    Participant
    Post count: 3

    is that already merged to actual retropie-version:
    https://github.com/RetroPie/RetroPie-Setup/issues/1061
    https://github.com/RetroPie/RetroPie-Setup/pull/1098
    ?

    do i need to run the script (when, how) or is it run automaticly?

    any hint on blocked-keyboard issue? it seems only present if game-controlle is plugged…if not plugged i got the message from emulationstation that no gamepad is present (no access to menu), but i can go to console with ctrl+alt+Fx

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.