Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • sauerkraut
    Post count: 5

    Sorry to bother you guys again.

    I got my RetroPie set up and everything and currently i am running it with 1 Xbox 360 Gamepad (Wired) and 1 USB-Keyboard connected. When playing a game, i can press the ESC-key on the keyboard to get back to the emulator main menu, but can i do the same thing with some sort of controller button combination? I’ve tried countless combinations, but nothing works so far. (e.g. l3 + r3, holding several buttons for a few seconds, select+start+LT+RT, and so on)

    I’m asking this, because i’m planing on using the RetroPie with 2 360 Pads and without keyboard.

    Thanks in advance,

    Post count: 4

    As far as I know there is no pre configured gamepad button combination that will gring you back to the main menu. I think you have to go into the config files of the emulators you are using and set up those combinations yourself. For Retro Arch you can add a line the following lines to the config file in RetroPie/configs/all

    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "9"

    This will allow you to close out of the emulator when you hold the Back Button (button 8) and press the Start Button (button 9).
    If you are using gpSP you can load the emulator without a game (go to the folder that holds the gpsp script and type ./gpsp) This gives you options to change your gamepad button configuration as well as enabling a preset button combination to close out (select and right trigger I believe)

    As of yet I haven’t used any of the other emulators yet so I haven’t looked into their specific configs.

    Hope this helped

    Post count: 2

    i could not get this to work. i found similar lines input_enable_hotkey = “escape”
    input_exit_emulator = “escape”. neither the post above or the default works for me.

    Post count: 17

    I can confirm that with the last update (2.3) the input_exit_emulator_btn isn’t working anymore.

    I used to configure it with a Zero Delay USB acarde adapter and always worked (as with a USB SNES controller).

    After upgrading to 2.3 it stopped working.

    I tried many configuration files, but none seems to work.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.