Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • deadward
    Post count: 6

    Sorry if this has been asked before. I have searched and found nothing that can help.

    per Floob’s request

    Pi Model: 2
    RetroPie Version Used: 3.3
    Built From: SD image
    USB Devices connected: alot… to the RPI, 2 joystick/button arcade set-ups, usb hub link, Edimax EW-7811Un WiFi Adapter. To the usb hub, a fan link, two usb extender cords link
    Controller used: 2 joystick/buttons amazon link and ps3 controller using the wire
    Error messages received: N/A
    Guide used: (Mention if you followed a guide)
    File: (File with issue (with FULL path))
    Attachment of config files: (or use
    How to replicate the problem: try the set up?

    So I have crafted an arcade box to house my raspberry pi which is running 3.3. I have the two joystick/button set-ups directly plugged into the rpi. I have a wifi doggle plugged in as well(for easy ftp of new games). And finally, I have a hub plugged in. The hub is powered so my fan is not pulling power from the rpi and my ps3 controller isn’t pulling power. I noticed if I had too much stuff plugged in, I was getting the underpowered square in the corner.

    Here is a picture that may make this easier to understand…
    retropie arcade
    usb ports

    My hope was that when i wasn’t playing games using the joystick set ups I have, I could plug in a ps3 controller to that middle front port that has my usb extender cables in it. I can use the ps3 controller to navigate emulationstation, the main gui, but once I get into a game, it is just using the joysticks.

    I have gone into the /opt/retropie/configs/all/retroarch.cfg and change the index for “input_player1_joypad_index” to match my port. Herb made a video recently explaining which ports are tied to which players. So my usb hub is plugged into port 2. So I thought my usb extenders that are coming from the hub would be port 2/index 2. And like I said before, I can navigate the menus, but once I am in the games, nothing works on the ps3 controller.

    So then I went further and unplugged both joystick/button set-ups from the rpi and still plugged in my ps3 controller to the extenders. Same results and then I was left with not being able to get out of battle toads. haha.

    So then I went further and opened up the back of my arcade and directly plugged in my ps3 controller into port 0 of my rpi and for some reason, it didn’t work. I get the yellow text in the beginning of the game saying my ps3 controller wasn’t configured. I also tried to re-input my buttons through the RGUI of retropie. Same result.

    I know this is kind of an odd situation. It would be really cool if I could get it all working the way I want it to. Using a joystick is ok for certain games but others it just becomes clumsy, maybe it is just me.

    Here are the rest of the pictures if anyone cares. My marquee is still under construction. Waiting for the sticker to come in for my plexiglass.
    arcade box

    Post count: 1629

    If your PS3 controller says its not configured in yellow text at the bottom of the screen, it may be that you need to change this line in /opt/retropie/configs/all/retroarch.cfg

    input_joypad_driver = udev

    Then re-configure the PS3 controller in Emulation Station.

    Post count: 6

    Thanks. That works. I had actually set that while back, but hadn’t changed the index of the controllers. So I didn’t realize the change actually worked(ps3 controller was still 3rd) and had set it back.

    So right now, my only option of having the ps3 controller set to player 1 is to manually change the config(which requires a keyboard unless I am missing some fancy feature) or unplug the other two controller from the back. Both solutions aren’t really ideal. One requires me to carry around a keyboard with my arcade box and the other requires me to open up the back and unplug stuff.

    Is there a way to add a script that would dynamically change the index of the controller that selects the game? For instance, I have joystick/button controller 1 and 2 in index 0 and 1 and ps3 controller in index 2. When I select a game with joystick/button controller 1, it would set the index for player 1 to 0. Select with joystick/button controller 2 and it would set the index for player 1 to 1. And, you guessed it, select a game with the ps3 controller and it would change player 1 index to 2.

    I know you can set the controls per emulator or even per game. But it would be cool if I could just boot up the retropie, decide to play MK with a joystick, get tired of that, back out of the game, select the game with the ps3 controller, and that one be player 1 automatically.

    And I am not asking for a script, I just want to know if it is possible. Thanks.

    Post count: 1629

    This gives you a good overview on controller / player setup.
    Remember you can have a config file per game if that helps.

    Post count: 6

    Yes, I watched that video a few days ago. Which is why I knew about the indexes to start with.

    I am just asking if you think it is plausible to add a script that runs when a game is selected that will change the index of player 1 controller to the one used to select the game.

    EDIT: (FIXED!)

    I ended up fixing the issue by just changing how I had my controllers configured in the box. Since retropie seems to bypass ports that don’t have a controller plugged in, I simply put my external ports which are actually hooked to a usb hub, to index 0. So if I don’t have any controllers plugged into the external ports. It just skips them and my two joystick/button set ups are in index 1 and 2. So when nothing is plugged in externally. They are player 1 and 2. If I want to play with two ps3 controllers, I just plug two into the my external ports and that makes them index 0 and 1 since they are part of a hub, essentially now making my raspberry pi usb ports shift their indexes accordingly. Maybe no one cares…

    But this could be a handy solution to anyone doing something similar to mine. If you want to be able to dynamically change which controllers are 1 and 2 without changing the config file or unplugging stuff from the raspberry pi, use a hub in index 0.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.