Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • tpr70
    Participant
    Post count: 27

    I’ve noticed several games in AdvanceMAME seem to slow down a bit or the audio gets out of sync. I’ve tried overclocking the Pi and that doesn’t seem to do much. Any tips or tricks anyone might have tried in the config to squeeze a bit more speed out of the emulator or get the sound working better?

    Thanks for your help!

    dudleydes
    Participant
    Post count: 139

    I had similar sound problems with Bubble Symphony and Elevator Action Returns using AdvMAME 1.2 and 1.4. Both run fine in AdvMAME 0.94 on my rpi2 with default overclocking.

    dankcushions
    Participant
    Post count: 432

    yeah, don’t use advancemame :)

    but really, mame4all-pi is a great one for raw speed, and mame2003 is pretty much the same performance, supports a huge library, and has the benefit of being a libretro core (so uses all the automatic controller configuration, etc).

    tpr70
    Participant
    Post count: 27

    Actually, I think I found a solution that has worked in about 99% of the games I was having trouble with.

    In the advmame-1.4.rc settings there was this option:

    display_vsync yes

    and I changed it to:

    display_vsync no

    That seems to clear up a lot of the sound issues without distorting anything else.

    petrockblog
    Keymaster
    Post count: 1827

    had you enabled this yourself ?

    our default setting is to have this off

    tpr70
    Participant
    Post count: 27

    The initial setup I had was done by someone else so it’s very possible they enabled it and I didn’t notice. But I’m glad I figured it out because it’s working MUCH better now!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.