Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • zrontron
    Post count: 14

    Hi all,

    So, I just set up an RPi2 with the newest v3b2 image. Everything seems to run great, but the only thing I have a question on is configuring analog sticks with the PSX Emulator.

    I can get them to work if I go into the menu and edit the input settings. After that saving the configuration file and pasting that data into the “retroarch.cfg” file in the PSX emulator seems to work.

    Am I going about this the right way, or is there an ‘easier’ way? I only ask because these will end up being gifts for people who may be a little less tech savvy, so anything that is more automatic, especially if they were to swap controllers would be great.


    Post count: 42

    I believe by default the pad type is set to standard (meaning non analog).

    You can switch this by going to the libretro menu and core options, and selecting analog pad (see here if you need:


    Open /configs/all/retroarch-core-options.cfg and add (or change) these lines depending on what you want:

    pcsx_rearmed_pad1type = “analog”
    pcsx_rearmed_pad2type = “standard”

    Also note, if the pad is set to analog some games won’t pick up the input (unless this is fixed), bust a groove comes to mind.

    Post count: 14

    Thanks Dave. I did see that in another thread and tried it. It does seem to get me past the Ape Escape warning message, and I can actually play the game. However, pressing the right stick forward doesn’t elicit a response.

    Trying to play any other games with the [pcsx_rearmed_pad#type = “analog”] line seems to simply break the controls and no buttons respond, but my hotkeys to exit still work.

    Post count: 32

    Hi there,

    I think the easiest way is to add
    input_player1_analog_dpad_mode = "1"
    to the
    “1” will enable the left analog stick AND the dpad in all retroarch emulators.

    Post count: 14


    Yep, doing that definitely made the left stick work in all emulators. I’m still not getting any luck past the Dual Shock detection screen in Ape Escape.

    The only way I can get past it is by adding [pcsx_rearmed_pad#type = “analog”] to my retroarch-core-options.cfg file, but when that value is in there my controllers stop working in the rest of my PSx games.

    Totally ready to chalk it up to the game itself, not too worried about it, but was using that game since it sounded like that was the one to use to test out analog stick functionality.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.