Homepage Forums RetroPie Project Everything else related to the RetroPie Project 3/4 DK Cabinet. Launch emulationstation with a button. Need help please.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #6022

    Hi. My name is Eduardo and i´m from Spain. First of all I wanna thanks all the people that makes RetroPie. It´s cool.
    Recently i build a 3/4 scale Donkey Kong Cabinet whit a RPi and a 14″ TV. You can see the entire process of the construction (in spanish) in http://www.retrovicio.org/foro/showthread.php?27582-Donkey-Kong-quot-reducida-quot-con-Raspberry-Pi
    The cabinet start up in Donkey Kong game, but I want to be able to access to other mame games, so i put a button in the back of the cabinet. The idea is that when yo push this button, the cabinet exit from Donkey kong game and enter in emulationstation (I don’t like mame4all front-end, because it only show names, no snaps).
    Well, and this is is my problem: I modified a shutdown script in python found somewhere, for this purpose. The first script I tried was:

    import RPi.GPIO as GPIO
    import time
    import os
    GPIO.setup(17, GPIO.IN,pull_up_down=GPIO.PUD_UP)
    while True:
        if(GPIO.input(17) == False):
            os.system("killall mame")

    The problem is that ES start, but it stops in a black screen with a white pixel in the middle (the screen that appears when you start ES) and the RPi hang on. I see that this happens if you try to launch ES as root (try to type sudo su (enter), and then emulationstation (enter) and you understand me).

    If i replace os.system("emulationstation") with os.system("su -c 'emulationstation' pi") to execute ES as pi user, instead of root user, i have this message:

    lvl0: Error initializing SDL!
    Unable to open a console terminal
    Are you in the ‘video’, ‘audio’, and ‘input’ groups? is X closed? Is your firmware up to date? Are you using at least the 192/64 memory split?
    lvl0: Rendered failed to initialize!
    lvl0: Window failed to initialize!

    Any idea? Please, need help to finish this project. Thank you and sorry for my poor english.


    Running as root is right, normally it means the memsplit/CPU isn’t clocked high enough, have a look at my over clock thread and try some (my) settings..

    Sent from my Nexus 5 using Tapatalk


    Thank you very much Karloss for your answer. I try with this settings:


    but i have the same result…

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.