Homepage Forums RetroPie Project Controller Configuration in RetroPie 2x 360 Wireless controllers work, 3rd and 4th having issues

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #112894

    I’m running 3.3.1. I have the xbox drivers installed and have 2 wireless 360 controllers working great with the default setup of 3.3.1

    With this default setup when I power on controller 3 it won’t sync.

    Ok so I then follow the instructions at

    I’ve tried option 1 with no luck. It acts just like the default install for me where trying to power on and sync the 3rd controller just ends with the controller light turning off. No sync.

    Option 3 works the best but I still have an issue. I can get the 3rd controller sync’d but the issue is all the lights on each controller continue to flash which makes picking out the correct controller problematic.

    Is there anyone here that has 4 wireless controllers working w/ lights properly lit solid? I realize 4 player games are a small subset so maybe it isn’t likely many have come across this yet.


    Nevermind. I figured it out. The instructions on that page say to just place that code above the exit line. It doesn’t say delete the xboxdrv line above it that is already there. Once you do that it picks up all 4 wireless controllers.


    Hi dotbomb I’m still having issues getting my 3rd and 4th controller to sync up. They just go black.

    I used option 3 the init script. Here is what I did in order.

    1. I went to /etc/init.d/ I created a file called xboxdrv and copied the script into it… then saved the file.

    2. I went to /etc/default/ I created xboxdrv and copied the script into it and changed the variable to 4, for four wireless controllers.

    I rebooted the pi and still only two controllers sync up.

    I noticed the mention of the daemon -D Option, I don’t know what that means… maybe I left something out? If you could help please, I would highly appreciate it cause it’s driving me nuts!


    I feel your pain :)

    When you install the xbox 360 driver it writes to /etc/rc.local

    The initial setup that comes default is option 2 on this page

    Specifically it is set to look for only 2 controllers. When you attempt to load controller 3 and 4 they’ll go black because it is only looking for 2 total controllers.

    Edit /etc/rc.local and remove that default single line setup. I believe that should fix your issue.


    Thanks for the quick reply. That worked in getting all 3 of my controllers synced. But now retroarch is all messed up.. it thinks controller 3 is controller one and the buttons either don’t work or are switched around. I tried reconfiguring them from the main menu… and it didn’t help. :/ Any ideas? They aren’t working right in mame either.


    Did you try adding this?

    I didn’t have luck with the script myself. I had success with option 1 and option 2 on the wiki.

    If you have 3 xbox 360 controllers this is what you’d need.

    Option 1

    Option 2

    That wiki page could be updated to be clearer but the general idea on it is correct. You just have to look at the syntax at the default rc.local file for clues as to how to get it working for the most recent version of retropie.


    Also, if your controllers aren’t responding in the emulation station ui you probably need to remap them (adding trigger-as-button can shift the input numbers).

    Delete the configuration file emulation station controller config file
    rm /home/pi/.emulationstation/es_input.cfg

    Reboot your pi and go through mapping the controller again.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.