Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • Anonymous
    Post count: 4


    I just started with RetroPie and I absolutely love it. I’ve built in my Raspberry in a SNES console with the original working Power button, reset button and power LED. It looks awesome! If you want pic’s i can give them! :) But i have one problem which i can’t seem to fix.

    I searched and searched but could not find any answer so i’ll try my luck here.

    I’m having troubles with RetroPie controlling two controllers. Here is my setup.

    Raspberry Pi 1 with 4GB SD Card with RetroPie 3.5 installed (also tried a fresh 3.6)
    16GB USB Stick attached for the ROM Storage
    WiFi Dongle attached
    Wireless Keyboard and Mouse dongle attached
    D-Link 7 ports USB hub is powering the Pi and provides extra USB ports
    2 after market SNES cloned controllers, they are named in their chip “usb gamepad ”

    When starting Super Mario World in 2 player mode i can’t control luigi with the second controller, it does not react but it will only react on the first controller. Donkey Kong Country does not work at all, the D-Pad does not react. Super Mario Kart does not work at all. Can’t even press start or B.

    What i noticed:
    When starting the game when the automatic controller configuration is active it says that it sees the two controllers in that yellow text left below, It says USB Gamepad connected on 0 and after that on 1. So the controllers are recognized. Also they both work fine in Emulationstation. Havent tried another system. I did try instead of Pocketsnes the Snes9x emulator but that doesnt even work with the first controller.

    What i tried:
    * two different controllers (that SNES controller and an Logitech Dual Action) didnt work.
    * Tried to hard-code the controller configuration in retroarch.cfg with putting the autodetection to false and set the player1 and player2 controls. Saw a youtube video of 30 minutes about this :) didnt work afterwards.
    * deleting existing controller config, reboot and let emulationstation do the whole thing again. (Both the controller.cfg and the ES_config.cfg) First setup controller one, then from the menu setup controller two. Didnt work. Although the two controllers can be used in Emulationstation.

    I’m breaking my brains here on this. This afternoon i will try my Raspberry Pi 3 to see if that will work fine.

    Hope that somebody can help me!


    Best Regards,

    Post count: 4

    I also now tried the jstest /dev/input/js0 and js1 commands and both controllers are correctly seen by Linux… :(

    I started Retroarch gui setup and saw that the controllers are also correctly in there. When i checked system information it said that the VID/PID for both controllers are 0/0

    Tried my Rpi3 with the same USB hub and this worked fine with two players… :( :( :(

    Post count: 4

    So i did some more testing and have the following results.

    All emulators on the SNES side are having this issue.

    I tried the NES emulator and that works fine with 2 players.

    The only difference i could see between the Rpi1 and Rpi2-3 image is that for the 2-3 lr-snes9x-next is used and on the Rpi1 the snes9x is used. Also the snes9x is not working on the Rpi1.

    So i have the following questions. Why has the Rpi2-3 image the other emulator installed and how can i install this on the Rpi1? I tried it with Sudo Make and Make Install but it failed :(

    Any help will be greatly appreciated!

    Regards, Cletus

    Post count: 4

    So i tested and tested even did a source build same story.

    I found out that Donkey Kong, Super Mario World and Mario kart is not working properly or at all. I tested it with Super Dragon something and that worked fine! So i pressume it’s a rom issue rather than a Build issue. Does anyone knows if there is a fix for this or should i rather go Rpi2 for this because of the other emulators that are on there?


Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.