Here are the steps I have done.

1. Followed all instructions on the wiki
2. Set keyboard, locale, mem split to 256 (rev 2 board)
3. I did a binary install because I only wanted SNES/NES/Megadrive. I included all non-emulator installs except for SNESDev.
4. Added roms
5. Ran scrapper
6. Installed GPIO game adapter
7. Enabled SNES GPIO tool
8. Installed pikeyd (it polls PGIO pins to simulate a virtual keyboard. I couldn’t figure out how to get SNESDev to do multiple buttons so I went with pikeyd)
9. Installed pikeyd: added the make file to /etc, added “i2c-dev” in /etc/modules, added pikeyd.conf to /etc, commented out “blacklist i2c-bcm2708” in /etc/modprobe.d/raspi-blacklist.conf, and added “usr/local/bin/pikeyd -d” to /etc/rc.local.
10. Added custom splashscreen

Now when I start, it goes to the splashscreen, then goes black. I tried with RCA and HDMI and no luck. I have also tried un-doing everything I did with pikeyd, but it still does not work correctly. For the record, I have gotten everything to work with pikeyd, and without on other builds.