pappy
Participant
Post count: 5

Hi,

I made almost the same experience as lobreeze, maybe 1 of 10 roms worked for me with the SD-preinstalled mame emulator.

With version 1.9 now there is mame4rpi avaiable, I have to encourage every Mame-adicct to give it a try. Just perform a source-code install from the retropie-config script (which takes some time), get 0.375b5 roms and enjoy all those arcade game classics with sound on your raspi. It was a great pleasure to see Galaga, Defender, Donkey Kong etc. behaving exactly as almost 30 years ago…

After source-code install just go to “RetroPie/emulators/mame4rpi” and start the emulator my “./mame” or “./mame romname”. Your roms have to be in the subdirectory “RetroPie/emulators/mame4rpi/roms” (instead I made a softlink to the Retropie rom directory).

Other than spending my pocket money now I can input a coin by pressing “5” and start a game by pressing “1” at the keyboard :-)

Unfortunately the joystick settings im this mame emulator are slightly different and they are of course not changed by any RetroArch setting. Using <TAB> within mame you can change them, but I did not figure out, how to save these settings. Also, mame4rpi didn´t read any config file.

Finally I modified mame4rpi source code: I changed dir to “RetroPie/emulators/mame4rpi/src” to edit “inptprt.cpp”. After almost 15 years in IT-consulting it was a pleasure to use VI again, like in those old developer days.

E.g. if you change line 160 (or so)
{ IPT_START1, “1 Player Start”, SEQ_DEF_1(KEYCODE_1) },
to
{ IPT_START1, “1 Player Start”, SEQ_DEF_1(JOYCODE_1_BUTTON5) },
now your Button 5 will start games. Better change this line t to
{ IPT_START1, “1 Player Start”, SEQ_DEF_3(KEYCODE_1, CODE_OR, JOYCODE_1_BUTTON5) },
thus your keyboard will still work (caution: use DEF_3 instead of DEF_1!).

A “make” command in “RetroPie/emulators/mame4rpi/src” will recompile your mame4rpi.

Happy gaming!