I had the same problem. Sound only over RCA with Video over Composite. But no sound over HDMI.

The solution is to add a line in the config.txt which is located in /boot/config.txt

I edit the file over another linux PC. There you’ll see two partitions when inserting the sd card. The small one includes the config.txt. Just open the config.txt with gedit or something like that and uncomment the following line:

hdmi_drive = 2

This option forces the HDMI mode. It’s necessary if some TV’s or monitors wants to use the DVI mode but there’s no sound over DVI. So when you force the HDMI mode it doesn’t matter which TV or monitor you use.

It works great with sega megadrive, nes, snes emulators.

But I’ve still a problem with gamegear and sega mastersystem roms. Both use the osmose emulator and with this there’s still no sound.

Can anyone help me with the solution for the osmose emulator and HDMI sound??