dayfather
Participant
Post count: 9

Ok I’ve made some progress, first of all I noticed that I’d accidentally put all my Mega Drive roms in the Master System rom directory so I moved them. For some reason listing SNES roms seems to works again (or it always worked and I’m just confused) but attempting to list Mega Drive roms now crashes emulation station. I ran emulation station directly from command line instead of launching from OSMC and was then able to see the error it threw up on exit.

[code]
emulationstation: /home/pi/RetroPie-Setup/tmp/build/emulationstation/es-core/src/resources/Font.cpp:129: static UnicodeChar Font::readUnicodeChar(const string&, std:size_t&): Assertation ‘(c & 0xC0) != 0x80’ failed

/usr/bin/emulationstation: line 16: 479 Aborted $es_bin "$@"
[/code]

I’m assuming that there’s something wrong with one of the rom file names but looking through them I can’t see anything that stands out.

I just removed any non-ASCII characters with the following script:
[code]
find /home/osmc/RetroPie/roms/megadrive -type f -print0 | \
perl -n0e ‘$new = $_; if($new =~ s/[^[:ascii:]]/_/g) {
print("Renaming $_ to $new\n"); rename($_, $new);
}’
[/code]

It found one file name with a non-ASCII character, I can’t check if it worked since I’m at work ssh’s to my Pi (I’m a terrible employee, I know) but I’ll let you know if it solved the problem in case anyone else is experiencing a similar issue.