tipoto
Participant
Post count: 43

You have to use the correct romset :
https://github.com/retropie/RetroPie-Setup/wiki/MAME

It seems that you use mame-Libretro, so you have to use 0.37b5, but I don’t think this rom is in the romset, you should probably use FBA-Libretro instead, which uses another romset:
Romset Used: FBA 0.2.97.30 which is based on MAME 0.154 (Jul 2014)
https://github.com/retropie/RetroPie-Setup/wiki/FinalBurn-Alpha