aaroneusthegreat
Participant
Post count: 3

In the interest of not clogging the boards with unnecessary new topics I decided to post here to see if I could get some help with some mupen64plus problems.

I have gotten everything installed and running, however it seems that when I run mupen64plus through emulation station, it ignores my configuration in the ~/.config/mupen64plus/ directory and does whatever the heck it wants.

The weird thing is that if I run it straight from command line, everything is fine. The differences are pretty big too. For one thing, when running it from the command line, it has the proper resolution (1024 by 768) which on the tv I run it on, it fills the entire screen. Not only that, but the escape key will stop the emulator and everything is cool/

Now if I run it from emulation station, it runs in 640 by 480, and because of that the aspect is 4:3 and leaves two vertical black bars on either side of the screen (pillarboxed?). And the other big deal is that I can’t exit the emulator with the escape key. Also I’ve noticed there’s a bit of a performance drop when running it from emulationstation. I wonder if that has to do with ram usage or some other such resource issue.

Ideally I would like to have it work like it does from the command line: full performance, full screen, proper resolution, escape key exits back to emulationstation. Although in a perfect world I would love to exit using the L3 button on my Logitech controller as it is never used by the emulator, but as of yet I haven’t found any way of making this happen, even with mupen64plus using the proper configuration.

Any ideas would be greatly appreciated!