Post count: 57

I believe the raspberry pi setting for screen rotation is for the terminal and the x desktop gui.

It could be that the emulators that aren’t rotated have separate configuration files, but osmose seems to use the retroarch.cfg

Maybe its something to do with the GLSL shader? If you open the additional config file for the master system (/home/pi/RetroPie/configs/mastersystem/retroarch.cfg) then you can see that it has video_shader_enable = true. Maybe setting this to false could work.

It may be that it’s not supported by certain emulators, which would require additional code.

A fix all solution would be to obtain a hardware solution, though it would be super expensive.

I’ll do some testing and see what I can find out.