Post count: 13

Ok, I solved this already: I just decided to jump in front of a gun and go compile the latest xboxdrv (0.8.5) and indeed the VX-SA stick is recognized out of the box as a XBOX 360 controller, like it should in the first place.

Here’s a little step-by-step guide, if someone is having the same problem:

1. I would suggest to get everything else working first, if you have the normal wired 360 controller – set that up


3. Scroll down for “mattc”‘s instructions for compiling the xboxdrv 0.8.5 and follow those instructions closely:
As “mattc” says: the compiling process can take up to 2h (mine took little under 1,5h with Model B Rev 2), so do not panic. The process also throws a lot of swp {b} warnings, which is apparently ok, so don’t panic on that one either. :)

4. After a boot everything should be working. If you didn’t have original 360 controller, now you have to setup the Hori stick. If you did configurate the original 360 controller in step 1., you’re ready to go! You might want to put an argument –dpad-only in your rc.local as the stick uses only d-pad inputs.

5. Might be a good idea to make a separate backup of the image at this point also.

“mattc” also mentions in the end of his great n00b friendly instructions, that he got his F310s working also with kernel update. I haven’t tried if it’s the case with Hori RAP also, because this seemed to work just fine with me. I might try that though at some point.