danmanx
Participant
Post count: 10

Thanks guys! I really appreciate the help here!
video_threaded=true
sound rate to 44100 did it for me!

I also turned off vsync and I’m about to change the RAM to a more healthy split as per whise’s advice.

I can finally play Mad Dog McCree on SegaCD!