I think you need to add this line to retroarch.cfg:

video_aspect_ratio_auto = false

According to the retroarch.cfg config file:

If this is true and video_aspect_ratio is not set,
aspect ratio is decided by libretro implementation.
If this is false, 1:1 PAR will always be assumed if video_aspect_ratio is not set.

Here is the rest of the config options for retroarch.cfg for reference: